Engine Code help ??? - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 12-03-2012, 07:17 AM Thread Starter
Compression Ignition Addict
 
Join Date: Oct 2010
Posts: 295
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 4 reviews
Engine Code help ???

I had these codes pop up on my H&S tuner. I cleared them all and then about 3 days later they popped up again. Are they related. Is this a common one? Is the Fan Speed Sensor Cheap? Is this the cooling fan? Are these sensors cheap or crazy expensive?

P2563 Turbocharger Boost Control Position Sensor Circuit Range/Performance
P0480 Fan 1 Control Circuit
P0528 Fan Speed Sensor Circuit No Signal

Are these all related?

2009 F450 King Ranch 4x4 CCLB Dually
- H&S Mini Maxxx Hot Damn 300 tune
- AirDog 2 165
- S&B intake
- afe 4" Race Downpipe
- afe DPF, Cat, and Muff Delete
- Sinister Complete EGR Delete
- BD Performance Intercooler Boots Double Clamped
- Mag Hytech Tran Pan
- All Redline Synthetics
- Ravelco so this truck does not get STOLEN like my last!!!
Humvette is offline  
post #2 of 4 Old 12-03-2012, 07:27 AM Thread Starter
Compression Ignition Addict
 
Join Date: Oct 2010
Posts: 295
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 4 reviews
Well i called the dealership and they were little to no help!

uh sir how could you be reading these codes LOL!!!

Is there a fan speed sensor that is external to the clutch assembly?

They also said there is not a TurboBoost control sensor???

2009 F450 King Ranch 4x4 CCLB Dually
- H&S Mini Maxxx Hot Damn 300 tune
- AirDog 2 165
- S&B intake
- afe 4" Race Downpipe
- afe DPF, Cat, and Muff Delete
- Sinister Complete EGR Delete
- BD Performance Intercooler Boots Double Clamped
- Mag Hytech Tran Pan
- All Redline Synthetics
- Ravelco so this truck does not get STOLEN like my last!!!
Humvette is offline  
post #3 of 4 Old 01-15-2013, 10:27 AM Thread Starter
Compression Ignition Addict
 
Join Date: Oct 2010
Posts: 295
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 4 reviews
found the problem my connector between the engine wiring harness and the clutch fan failed!!!

2009 F450 King Ranch 4x4 CCLB Dually
- H&S Mini Maxxx Hot Damn 300 tune
- AirDog 2 165
- S&B intake
- afe 4" Race Downpipe
- afe DPF, Cat, and Muff Delete
- Sinister Complete EGR Delete
- BD Performance Intercooler Boots Double Clamped
- Mag Hytech Tran Pan
- All Redline Synthetics
- Ravelco so this truck does not get STOLEN like my last!!!
Humvette is offline  
post #4 of 4 Old 02-06-2013, 03:22 PM
Premium Member
 
Join Date: Jul 2012
Location: Philadelphia
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I had the same fan speed sensor code and I had a trans sensor code come up at the same time. When ur fan speed sensor came on was ur fan running all the time? Mine stays on and I my trans temp gauge is not reading anything? I wonder how these two are realted or is it just a freak thing? And mine all started after I was running hard up my favorite hill, Like 30 to 90mph hard.
Drew11474 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome