motor shut off, darn near wrecked. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-18-2012, 05:00 PM
Member
 

Join Date: Aug 2011
Posts: 70
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
motor shut off, darn near wrecked.

2008, 112k. stock and orginal.

motor shut off twice today. once at a stoplight. check engine light came on. went by advance and scaned. found a P0194. cleared it and truck ran good all day. on the way home in a sharp turn, 25 mph and engine at idle, it shut off again. damn near wrecked. BTW. it starts right up.

question. "fuel rail pressure sensor circuit intermittent." does that mean there is a circuit problem "electricial, or sensor" or does that mean there is a problem with the fuel pressure?

crap. I'm sceduled to go to NC to pick up my active duty son-in-laws car and deliver it to Egland AFB on the 27th. Cant mess that up. they are counting on me for that job.

What are possible causes?

thanks
Dale

Last edited by dnifong; 11-18-2012 at 05:12 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-18-2012, 06:53 PM
Serving Our Country!
 

Join Date: Apr 2011
Location: Nevada
Posts: 233
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Check your fuel filters! Have you replaced them lately? If they are in good shape it could very well be the fuel pump starting to go out on.
Reply With Quote Quick reply to this message
  #3  
Old 11-20-2012, 05:24 PM
Member
 

Join Date: Aug 2011
Posts: 70
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
fuel filters were changed 1000 to 1200 miles ago. Is the fuel pump a common failure item on this truck? thanks, dale
Reply With Quote Quick reply to this message
  #4  
Old 11-22-2012, 04:18 PM
Member
 

Join Date: Aug 2011
Posts: 70
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
update. it ran good for a couple of days. today it shut off again. has anyone changed the fuel rail pressure sensor? if so how hard, or how much time involved?

thanks
Dale
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:01 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors