LOW POWER - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-22-2012, 06:21 AM Thread Starter
Powerstroke.org Rookie
 
tkpatter1's Avatar
 
Join Date: Aug 2010
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
LOW POWER

I have 2008 F350. Runns smooth no missing or jumping but is weak. will not pull hard or accelerate when needed. Warning light drain fuel water seperator appeared. I stopped by dealed and picked up filters just in case. Truck just rolled 50k. Drain lever is broken off so I removed plate and drained. Removed old filters and replaced with new. No leaks so I test drove and low power still issue. I had 06 fuel water sensor required cleaning when corroded. But never dropped down into low power mode.
Thats what this feels like that the power is limited by parameter bolcking power for engine protection mode. Does this sensor require cleaning or replacement to reset power mode or am I way off base?
tkpatter1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome