Sounds like i have a supercharger! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-04-2012, 09:52 AM
Powerstroke.org Fanatic
 

Join Date: Sep 2009
Location: Chicago
Posts: 103
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sounds like i have a supercharger!

My 08 with 118K has a rpm based noise that sounds like it has a loud supercharger. seems to be coming from the turbos....which have been replaced 10K ago.
It sounds nice lol..but i dont thing its normal. is at its loudest when i push the throttle 75%...and with 20-30lbs of boost.
The truck drives absolutely fine.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-04-2012, 02:43 PM
Compression Ignition Addict
 

Join Date: Mar 2012
Location: Alberta
Posts: 1,314
Thanks: 3
Thanked 10 Times in 10 Posts
Feedback Score: 0 reviews
Could you post a video of the sound?
Reply With Quote Quick reply to this message
  #3  
Old 10-04-2012, 05:03 PM
Compression Ignition Addict
 

Join Date: Jun 2011
Location: covington
Posts: 1,763
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i know what your talking about. pretty sure thats normal. or atleast every 6.4 i have rode in has done it
Reply With Quote Quick reply to this message
  #4  
Old 10-05-2012, 05:57 AM
Member
 

Join Date: Aug 2010
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Does it make the noise when your getting on the throttle and you can hear it again when you let off? Almost like a whine? I just bought a 2010 6.4 and have the same issue interested to see what everyone thinks.
Reply With Quote Quick reply to this message
  #5  
Old 10-05-2012, 07:31 AM
Powerstroke.org Fanatic
 

Join Date: Sep 2009
Location: Chicago
Posts: 103
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Guys, when the boost goes up, its a VERY loud whine. i took it to my diesel mechanic that replaced the turbos, and he said its possible i have a leak..
Reply With Quote Quick reply to this message
  #6  
Old 10-05-2012, 09:53 AM
Compression Ignition Addict
 

Join Date: Nov 2008
Location: Ontario
Posts: 1,609
Thanks: 2
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
if it didnt do it before but it does now then its not normal. could be up pipe leake (im just guessing) check for black soot behind the turbos
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:30 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors