Crazy hissing noise under boost! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-23-2012, 07:33 PM
Member
 

Join Date: Feb 2011
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Crazy hissing noise under boost!

I just got back from my mechanic who did an oil change and changed out the fan clutch on my 2008 F450.

The truck as an S&B intake, H&S mini maxx, 5" turbo back exhaust and an EGR delete. Its had these mods for 20k miles with no issues.

About 70miles into my way home I heard a really loud hissing noise from what first sounded like it came from under the drivers side of the dash. I pulled over and noticed that my check engine light had come on.
The truck had thrown a "turbo/supercharger performance" code. I can't remver the actual number.

I cleared the code and drove the truck home slowly.. still making a crazy hissing noise but not throwing the engine light back on.

I checked the turbo hoses and it didn't really seem like they were ripped, plus they are on the passenger side so it wouldn't seem like that would be the culprit. the truck would still put out a healthy amount of boost and I didn't really notice a loss in power. I wasn't pushing it hard after this happend so I can't really be sure about the power loss but it wasn't noticeable at normal highway speeds.

The truck is going into a local diesel shop in the AM (they are Duramax specialist so i'm a bit hesitant trusting them with my truck).
My mechanic is about 100 miles away and I have to leave for a race weekend day after tommorow so I don't have time to go back to him.

Any idea on what this could be so I can maybe steer the local shop in the right direction?

Thanks in advance!

Last edited by canada6.0; 07-23-2012 at 07:45 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-24-2012, 09:21 AM
Compression Ignition Addict
 

Join Date: Nov 2008
Location: Ontario
Posts: 1,592
Thanks: 2
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
I've heard of this before it's a cracked up pipe I believe.... Someone else will chime in but I think that's what it is
Reply With Quote Quick reply to this message
  #3  
Old 07-24-2012, 11:16 AM
Compression Ignition Addict
 

Join Date: Oct 2010
Posts: 4,155
Thanks: 14
Thanked 53 Times in 52 Posts
Feedback Score: 0 reviews
Ya i would also guess a leaking up pipe.
Reply With Quote Quick reply to this message
  #4  
Old 07-30-2012, 03:35 PM
Member
 

Join Date: Feb 2011
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So we figured out it was a broken Back Pressure Sensor Pipe.

I never heard of that before but apparently is a common problem.

Thanks for the help guys!
Reply With Quote Quick reply to this message
  #5  
Old 08-10-2012, 04:53 PM
Powerstroke.org Rookie
 

Join Date: Jul 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I am also having the same issue. How was it replaced? Was it a cab off? Thanks in advance
Reply With Quote Quick reply to this message
  #6  
Old 08-11-2012, 08:35 AM
Compression Ignition Addict
 

Join Date: Jul 2009
Location: Down a dirt road
Posts: 569
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
When mytranny locks under load it makes a hissing noise:. Sounds cool but is this the same thing? Hurting performance?
Reply With Quote Quick reply to this message
  #7  
Old 08-11-2012, 08:40 PM
Member
 

Join Date: Feb 2011
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by brewda View Post
I am also having the same issue. How was it replaced? Was it a cab off? Thanks in advance
I didn't do the fix, I dropped it off at a diesel shop by my shop and they had it fixed in an hour. Was a cheap fix $150ish with the diagnostic, part and fix.

Quote:
Originally Posted by hammett88 View Post
When mytranny locks under load it makes a hissing noise:. Sounds cool but is this the same thing? Hurting performance?
I dont think that's the same issue. Mine was insane loud and definetly hurt performance. Basically lost all my low end grunt, my tweaked 6.4 was running like my old stock 6.0.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:15 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors