Boost problem - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-11-2012, 09:50 PM
Powerstroke.org Rookie
 

Join Date: Feb 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Boost problem

I have an F-450 service truck and for the last 7 months I have had problems with boost during regen. I have a video to prove it and will try to attach...the video shows me going from 0-75mph with my foot on the floor. I've replaced the turbos, an exhaust manifold, the exhaust filter, and still the same. When it is not in regen, she'll run great, bout 34 psi boost, but it is just not right and want to know if anyone else has had this problem and what they did to fix it. I've also noticed that the harder I run it, the less boost I get out of it. At times, I get 15 to 22 and it fluctuates. I am a natural gas compressor mechanic and I know that if this is the way they run, Ford would have never sold this. The truck has 145K on it and it is on it's 2nd engine as of 97K so please help!!!!!!!! I've had it to Ford and aftermarket services and still no fix.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:32 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors