looking for help Code-P0231 - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 06-20-2011, 09:12 AM Thread Starter
Powerstroke.org Fanatic
 
Remi19's Avatar
 
Join Date: Jan 2010
Posts: 139
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
looking for help Code-P0231

P0231- fuel pump secondary circuit low

Rugger311 had the same code and Ford was able to fix it by replacing the inertia switch due to a short. I have also read that the fuel pump wireing hareness may be causing this. i don't want to have the cab pulled. Anyone had this problem?

Replaced fuse for secondary fuel pump and truck ran fine for a few weeks, then same code again. Truck would eventauly fire up but had to clear codes several times before truck would fire. never died once the truck started. always seemed to happen after driving in the heat of the day. Black max tunned and have 126k miles on 2008 job 1 F-250

Any ideas? Thanks

Last edited by Remi19; 06-20-2011 at 09:53 AM. Reason: wrong
Remi19 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 06-24-2011, 08:03 PM
Banned
 
Join Date: May 2009
Location: (518) on the boarder of MA+CT
Posts: 1,023
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to PowerstrokeTech82787
Quote:
Originally Posted by Remi19 View Post
P0231- fuel pump secondary circuit low

Rugger311 had the same code and Ford was able to fix it by replacing the inertia switch due to a short. I have also read that the fuel pump wireing hareness may be causing this. i don't want to have the cab pulled. Anyone had this problem?

Replaced fuse for secondary fuel pump and truck ran fine for a few weeks, then same code again. Truck would eventauly fire up but had to clear codes several times before truck would fire. never died once the truck started. always seemed to happen after driving in the heat of the day. Black max tunned and have 126k miles on 2008 job 1 F-250

Any ideas? Thanks
Do what i did for the Vref going to the dpf, find the connector for the secondary fuel pump going from the pcm to the pump and every connector inbetween. Find what pins that wire runs through disconnect the pcm connector and each connector 1 at a time and load test the circuit. If the light bulb is dim-have a short in the harness screw wasting time pulling a cab for that, if i did that and put Mtime in for a wire overlay ford would laugh thier balls off at me. SO just get a spool of wire and splice it in where theres good known current and run that wire to the connector with the wire thats in question. Leave about 4 inches off of the connector for the 2ndary fuel pump. Problem solved.
PowerstrokeTech82787 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome