TRUCK DIED - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 05-06-2011, 05:30 AM Thread Starter
Compression Ignition Addict
 
Join Date: Sep 2006
Location: La
Posts: 429
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
TRUCK DIED

OK, after cleaning out my fuel Sep. i put it back together. fairly easy, no leaks, So i decided to take it to work, At lunch there was puddle of diesel about where the Sep. is. and it was dripping, I cranked it up and it stopped leaking, OK no problem i'll get a gasket on my way home, Well Before i could get out of town it died at the light, fuel drain from sep. SO now i'm getting the New gasket, on my way home today. But why did it quit running like that AIR in lines? it was running good b4 that. ANd what do i have to do to get it back on the road again? ? change gasket and???? prime the system? I'm hoping after the gasket install it primes up doing the 30 sec. on thing (6) times, What else??

D.N.S.
08 250 3" Lift
Diamond eye 4" Down-pipe back
No Limit Fab CAI
No Limit Fab. Egr Delete
35" nitto's
H&S Mini
RichardT is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-06-2011, 12:23 PM
Compression Ignition Addict
 
Join Date: Mar 2011
Location: Great Falls, VA
Posts: 869
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 11 Times in 11 Posts
Feedback Score: 0 reviews
sounds like some of the fuel came out of the lines between the engine filter and the sperator.. and it just wasn't primed.. i would install the new parts your getting.. prime it.. and it should be good.. if its still dies.. might be another small problem you might be overlooking.. doesn't sound like anything major

Kris

2008 Ford F250 6.4L Crew Cab Short Bed King Ranch
3.5" ReadyLift Leveling Kit, 37x13.5x20 Toyo MT's on stock 20's, Dual Steering Stabilizer, Livewire w/ IDP, KEM, Gearhead, S&B, 5" Flo-Pro, Rudy's EGR Delete and Cold Side Pipe, CCV
p8ntballn2 is offline  
post #3 of 3 Old 05-07-2011, 06:10 AM Thread Starter
Compression Ignition Addict
 
Join Date: Sep 2006
Location: La
Posts: 429
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Got it going but now my check engine light stays on sounds and runs alright but the light comes on as soon as I turn the key on and stays on manual says emissions not sure I may try disconnecting the batts and c what happens in the mean time it will be limited use thanks to my good ole 7.3 Maybe old but very reliable

D.N.S.
08 250 3" Lift
Diamond eye 4" Down-pipe back
No Limit Fab CAI
No Limit Fab. Egr Delete
35" nitto's
H&S Mini
RichardT is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome