problems persisting after new HPFP! Help - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 04-12-2011, 08:13 AM Thread Starter Fanatic
Join Date: Nov 2008
Posts: 94
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy problems persisting after new HPFP! Help

took my 6.4 into the dealer 3 weeks a go for loss of power and check engine code p0088 (fuel rail/system pressure) too high. tech said it needed a new hpfp and so they went ahead and replaced it. truck seemed to be ok when i got it back except whenever i got back into the truck after driving it for a while there would be a loss of power right when i started it up and got going. id get on the gas and it would just have no power but would then clear up pretty quick and start driving normal. this always happens everytime i get back into the truck and get going. now im getting a p0087 (fuel rail/system pressure) too low and p2291 (injector control pressure) too low-engine cranking. im not always getting a check engine light but i can feel the truck running funny and when i run diagnostics on the dashdaq, those are the codes its producing.

can anyone tell me whats goin on?
OC Stroker is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome