Some help please.... - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 04-07-2011, 01:14 PM Thread Starter
strokethis35's Avatar
Join Date: Apr 2010
Posts: 46
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Some help please....

I have an 03 with the 6.0. Yesterday while leaving work my truck seemed to misfire and have zero power. put it in park reved it up, put in drive and it was back to normal. run good for another 8 hrs last night. Go to get in this morning, turn my key on all lights in the dash turn on and then i go to turn it over. NOTHING. So after searching this site i found a thread on this problem. I pull the yellow wire and jump it, truck turns over but doesnt start, so i try it a few more times and finally it fires up. So out test driving it it does the whole missfireing and losing all power. What is causing this????? I rev it up and back to normal. Also i dont think my fuel pump was cycling on when it wouldnt start. no buzzing noice anyways. Any ideas on this? First time diesel owner so i have very little knowledge on these trucks, so any info and help will be amazing right now. Truck is stock except an exhaust system and cold air intake. Roughly 76,xxx miles. Thanks for your help

strokethis35 is offline  
Sponsored Links
post #2 of 2 Old 04-07-2011, 05:37 PM
Compression Ignition Addict
Join Date: Apr 2009
Location: On the road
Posts: 172
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Originally Posted by strokethis35 View Post
I have an 03 with the 6.0. Yesterday Harley
Hey bud try the 6.0 forum... Those are different animals then our 6.4's.
Good luck,

13F --U.S. Army Retired
2010 F350 KingRanch (with some options )Super Duty 6.4 CC/SWB Spartan delete w/250, AirDog2 D-165, Full EGR Delete, CAI, and sweet exhaust :thumb
strivingfirst is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome