egr changed now only getting 23psi boost help! - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 03-12-2011, 07:15 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2011
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
egr changed now only getting 23psi boost help!

So my truck's egr vavle went bad @ 30000 miles. The dealer towed it in and changed it out. When I got it back it only gets up too about 23-25 psi of boost. I took it back to the dealer and they said nothing is wrong so they just reflashed it. I always used to get up to 33-35 psi of boost. When I talked to them they said that the max factory boost is 30 psi. I filed a complaint with FoMoCo and now the dealer wants another whack at it. It is scheduled to go in next Wednesday, but I am just wanting your take on it so I'm not going into this blind. Was my truck over boosting originally?
Jambat1 is offline  
post #2 of 5 Old 03-12-2011, 09:35 AM
Powerstroke Techie

 
Join Date: Nov 2010
Location: South Fayette/Pittsburgh PA
Posts: 5,824
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Thanks: 33
Thanked 143 Times in 129 Posts
Garage
Feedback Score: 4 reviews
no 23 is way low.

what were the original symptoms that occured before you had it towed in?

-Matt

Ford Senior Master Tech

2015 F-250 XLT 6.7L

2006 F-250 6.0L SOLD
sinner6.0L is offline  
post #3 of 5 Old 03-12-2011, 09:41 AM
Member
 
topcop45's Avatar
 
Join Date: Sep 2009
Posts: 68
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I thought 28 psi was max at factory stock
topcop45 is offline  
post #4 of 5 Old 03-12-2011, 10:40 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2011
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My wife hopped in the truck to take it to work and when she pulled out of the driveway it stalled. She couldn't get it started back up. When I went out to check it out I could get it started, but it idle @ real low rpm like 350-400. I couldn't get it above that. It was running so rough I just shut it down and called the dealer. That's when they said it was the egr valve.
Jambat1 is offline  
post #5 of 5 Old 03-13-2011, 06:46 PM
Powerstroke Techie

 
Join Date: Nov 2010
Location: South Fayette/Pittsburgh PA
Posts: 5,824
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Thanks: 33
Thanked 143 Times in 129 Posts
Garage
Feedback Score: 4 reviews
with that much carbon around to plug up the valve it's possible your EBP tube is also clogged up.

let us know what the other dealer finds

also you may also want to consider running a fuel additive/cetane boost. i don't know how much idling you do but 30k is a short life for an egr valve. it does happen don't get me wrong but fuel quality may be to blame

-Matt

Ford Senior Master Tech

2015 F-250 XLT 6.7L

2006 F-250 6.0L SOLD

Last edited by sinner6.0L; 03-13-2011 at 06:50 PM.
sinner6.0L is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome