Throwing Codes and turck losing power. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-21-2011, 10:29 PM
Powerstroke.org Fanatic
 

Join Date: Nov 2008
Posts: 94
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy Throwing Codes and truck losing power.

i have an 08 6.4 with spartan's tunes. i haven't upgrade to anything new ever since upgrading to the strategy flash. i normally run the 310 tune and sometimes the 275.

about a month ago i started noticing this faint humming sound coming from the engine bay whenever i let off the gas somewhat abruptly. i compare the sound to how bad brakes sound when coming to a stop. i also notice this sound when the torque converter locks up. the power seemed to be uninterrupted so i was hoping that it was something temporary and would just go away. silly me...

last week i took the truck into the dealership for an oil change. i always tune it to stock/dpf off when going into the dealer. when i got it back i hopped on the highway to head home and noticed i was stepping on the gas petal nearly 3/4 of the way and it wasnt going anywhere. i floored it and it just started choking. i pulled over at the next exit and turned the truck off for a couple mins and started it up again and it ran fine but only for a few blocks. this time the engine light came on. i ran the code and it said p0088 fuel rail pressure to high. i cleared it and it ran fine again but did the same thing after a few blocks. i pulled over called spartan and got a hold of mick. informed him of the situation and he told me to put it back to the tune i normally run it on and see if it still does it. he said if it doesn't than there probably isnt an issue but if the problem persists than there's probably something wrong internally. i did as he said and it ran fine. although i can still hear that faint humming sound but its now gotten louder and it also comes on when i hit the brakes!

just today while still running the 310 it started choking again and threw the same code. i keep clearing it and it keeps coming back and sometimes it'll choke when i get on it and sometimes it wont. ive tried several different tunes, even the lower hp ones and its doing it with all of them now.

does anyone here have any idea what this could be. are my fuel rails toast? please any advice or comments would be greatly appreciated. thanks...

Last edited by OC Stroker; 02-22-2011 at 04:06 PM. Reason: spelling
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:53 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors