Engine Chugging with no power after fuel seperator replacement and regen - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-18-2011, 03:17 PM Thread Starter
Compression Ignition Addict
johnny9r's Avatar
Join Date: Nov 2009
Posts: 261
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Engine Chugging with no power after fuel seperator replacement and regen

Hey Guys,

A couple of days ago I had my fuel seperator changed as the drain system had failed for some reason.

I also had an oil change at that time.

Today driving home from work my truck went into regen so i went for a little longer drive to let it run completely through the cycle. After the regen finished i headed home. Getting off the highway i got on the truck just a little to get blended with traffic and the truck ran fine. When i went to accellerate from the next stop light the truck started to studder at low RPM and had no power. I limped home at like 25 - 25 MPH with some white smoke coming out of the tailpipe.

Help what could be going wrong.

08 350 Lariat CC LB
johnny9r is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome