Does anyone else's 6.4L cough/sputter between 1,700-1,800 rpms? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 12-22-2010, 07:58 AM Thread Starter
Join Date: Dec 2010
Posts: 84
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Does anyone else's 6.4L cough/sputter between 1,700-1,800 rpms?

My truck seems to cough/sputter between 17-1800 rpms. I recently had it returned to stock for about 3 weeks and it did the same thing but not as bad as tuned. I had the egr vavle replaced while stock and thought maybe that had something to do with it, but nothing changed. I don't remember it doing it this summer while temps were warmer, but it definately shows up now that temps are cool (not sure if this has anything to do with it or not). I am running the spartan on 75hp tune for the winter, dpf off. The power also seems down?

Anyone have, any ideas?? THanks!
darkshadowgray08 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome