wrench light after oil change - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 10-23-2010, 06:49 AM Thread Starter
Compression Ignition Addict
 
austin229's Avatar
 
Join Date: May 2009
Posts: 172
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
wrench light after oil change

I just swapped to 5w-40 from using 15-40 and this morning my wrench light came on. The oil level is good but I'm thinking the oil is to thin.any one else had this happen?

2010 F-250 Lariat Fx4
H&S mini maxx
KEM
S&B intake
MRBP CAC pipe
flo-pro 5" exhaust 4" dp
5.5" Icon & Bilstein 5160
Hellwigs
37x13.50x20 Toyo m/t
austin229 is offline  
post #2 of 4 Old 10-25-2010, 03:04 PM
Emergency Services

 
Join Date: Nov 2007
Location: Hawaii
Posts: 626
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
What codes came up? Did you take to the dealer?

2008 F-350 6.4 Power Stroke 4X4
CC LWB SRW Auto 3.73's
BigIslandBoy is offline  
post #3 of 4 Old 10-25-2010, 03:18 PM Thread Starter
Compression Ignition Addict
 
austin229's Avatar
 
Join Date: May 2009
Posts: 172
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I didnt have a cel or code on the h&s. The wrench light went off as soon as I cut the truck off and restarted it. Must have had something to do with the eot being cool and on a higher tune. It's running fine and hasn't done it again. I'm probably going to go back to 15-40 soon anyway though

2010 F-250 Lariat Fx4
H&S mini maxx
KEM
S&B intake
MRBP CAC pipe
flo-pro 5" exhaust 4" dp
5.5" Icon & Bilstein 5160
Hellwigs
37x13.50x20 Toyo m/t
austin229 is offline  
post #4 of 4 Old 10-27-2010, 10:12 AM
Compression Ignition Addict
 
Join Date: Mar 2009
Posts: 407
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
The 5w40 is fine for the 6.4. Actually, mine ran better (fuel mileage) on the Rotella T6 5w40 than 15w40. I didnt like the 15w40 at start up. Just too thick when the motor's cold.
BlueF350 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome