crank, no start im a tech ready to pull body - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-11-2010, 05:01 AM
Powerstroke.org Fanatic
 

Join Date: Aug 2010
Posts: 110
Thanks: 0
Thanked 3 Times in 1 Post
Feedback Score: 0 reviews
crank, no start im a tech ready to pull body

chime in if you are a technician or very well versed in the 6.4. we have a crank no start condition and starting to pull body now, dont have a cause yet but best guess is injectors and there is only one way to get to them for testing
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-12-2010, 04:04 AM
Powerstroke.org Sponsor

 

Join Date: Jan 2009
Location: Hillsborough, NC
Posts: 1,011
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What is your fuel rail pressure? You can get to the injectors by removing the valve covers cab on.
Reply With Quote Quick reply to this message
  #3  
Old 10-17-2010, 04:23 AM
Compression Ignition Addict
 

Join Date: Aug 2010
Location: central texas
Posts: 394
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Any codes? Alot of things show up on the ids that don't on a generic scan tool.
Reply With Quote Quick reply to this message
  #4  
Old 10-18-2010, 02:35 AM
Powerstroke.org Fanatic
 

Join Date: Aug 2010
Posts: 110
Thanks: 0
Thanked 3 Times in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by greasltn View Post
What is your fuel rail pressure? You can get to the injectors by removing the valve covers cab on.
rail pressure of about 6000 psi cranking
Reply With Quote Quick reply to this message
  #5  
Old 10-18-2010, 02:38 AM
Powerstroke.org Fanatic
 

Join Date: Aug 2010
Posts: 110
Thanks: 0
Thanked 3 Times in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by dazed01 View Post
Any codes? Alot of things show up on the ids that don't on a generic scan tool.
no codes, considered clogged dpf... disconnected but still nothing

we are using the ids, was able to do a buzz test and all responded so its not injector electrical

basically at this point we have the body off, have replaced the injectors, the dpf, and turbo (it had a cracked housing, wouldnt cause our no-start but needed repair none the less)
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:07 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors