Possible Turbo Problem - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 07-15-2010, 10:04 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Possible Turbo Problem

When i start from a stand still the turbo does not build boost and the exaust rolls out black smoke it feels like its getting to much gas or not enough air once i start moving there is no problem seems like the turbo is fine ANY IDEAS
rcg2007 is offline  
post #2 of 5 Old 07-15-2010, 10:16 AM
Member
 
Join Date: Apr 2008
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
What makes you think the Turbo is fine?
Joshyutah is offline  
post #3 of 5 Old 07-15-2010, 10:17 AM
Powerstroke.org Sponsor

 
greasltn's Avatar
 
Join Date: Jan 2009
Location: Hillsborough, NC
Posts: 1,011
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
All turbos take time to build boost. How long does yours take before it cleans up the smoke?

-John
Rudy's Diesel Performance - 919-383-9300 - Diesel Tech

WWW.DPFDELETEKITS.COM
greasltn is offline  
post #4 of 5 Old 07-15-2010, 10:27 AM
Compression Ignition Addict
 
mcflan's Avatar
 
Join Date: May 2009
Location: Cincinnati, Ohio
Posts: 1,650
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 9 reviews
You check the air filter element to make sure there isn't a clog? Or that it's too dirty?


Jon
03 6.0 F350 SD
SCT w/Matt's SRL
Zoodad
AFE Stage II
EGR Delete
Banks Monster Exhaust
Isspro Gauges
Studded, Lapped, and Bored
175cc Injectors
Powermax Turbo
Blue Spring FPR
Diesel Site Coolant Filter
AD2 Fuel System
Oil By-Pass System
My personally made Remote FICM/Board
mcflan is offline  
post #5 of 5 Old 07-15-2010, 11:57 AM
Compression Ignition Addict
 
dieselkane's Avatar
 
Join Date: Oct 2007
Location: Pocat-hell-hole, Idaho
Posts: 1,509
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by rcg2007 View Post
When i start from a stand still the turbo does not build boost and the exaust rolls out black smoke it feels like its getting to much gas or not enough air once i start moving there is no problem seems like the turbo is fine ANY IDEAS
Any codes in the system?
dieselkane is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome