Need some help ASAP, Please - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-20-2010, 09:07 AM
Powerstroke.org Rookie
 

Join Date: Jun 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Need some help ASAP, Please

My buddy has a 08 f250 4x4 6.4 with a auto. Yesterday they were driving and all the sudden the display said" pull over saftley". As soon as they pulled over the truck died. He said it would not crank at all after that, but if you pushed the truck forward, it would start. It has a CEL, but he has no way to pull codes. I am fixing to head that way with my code reader, but was just looking for some input on what to look for as far as problems.

Thanks
Ryan
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-20-2010, 09:36 AM
Compression Ignition Addict
 

Join Date: Dec 2006
Location: Lockport IL
Posts: 4,295
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 7 reviews
Send a message via AIM to dereku
Wow have no idea what could be wrong but makes me want a 6.9 IDI
Reply With Quote Quick reply to this message
  #3  
Old 06-20-2010, 10:18 AM
Powerstroke.org Fanatic
 

Join Date: Dec 2009
Posts: 114
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sounds like the DPF got to hot, mine did that 3 times before I did the delete. Give it a hour and it should fire right up.
Reply With Quote Quick reply to this message
  #4  
Old 06-20-2010, 04:51 PM
Powerstroke.org Rookie
 

Join Date: Jun 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well had the truck towed home and let it sit a while. Started right up and idled for a good bit. Went to drive it and as soon as you hit 65 mph, it did the same thing and died. Borrowed a SCT livewire to pull the codes as just got U0115, U2510 and U0100. Now as soon as you turn it on, it says cleaning DPF filter, then safely pull over and dies. Then it wont crank anymore. Im thinking the dealer is the next stop
Reply With Quote Quick reply to this message
  #5  
Old 06-30-2010, 12:35 PM
Powerstroke.org Rookie
 

Join Date: Jun 2010
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
you ever figure out the problem? i remember the job 1 engines had the problem with the regen process shooting flames out of the tailpipes. ford had a recall and their only fix at that time was to reflash the computer to make the engine de-fuel and give you only enough power to pull over and stop. once cooled, it would allow you to travel again.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:04 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors