6.4 losing power - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 04-24-2010, 08:05 PM Thread Starter
Premium Member
 
rstarr harley's Avatar
 
Join Date: Mar 2009
Posts: 134
Thanks: 1
Thanked 12 Times in 8 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
6.4 losing power

Ive got a 09 Harley f250 with 15,000 miles on it and today my truck lost a lot of power. It wouldnt not get up and go at all! The engine just got loud and it didnt move. At first i thought it was going into limp mode but it wasnt in regen. Then i thought it was the turbo but it was still showing pleanty of boost. The check engine light finally came on. I still have have no clue what it could be . Any ides would be appreciated.
rstarr harley is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 04-25-2010, 06:18 AM
Compression Ignition Addict
 
Join Date: Dec 2006
Posts: 229
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
sounds like limp mode, what codes are on the computer?
First_Ford is offline  
post #3 of 3 Old 04-25-2010, 04:49 PM Thread Starter
Premium Member
 
rstarr harley's Avatar
 
Join Date: Mar 2009
Posts: 134
Thanks: 1
Thanked 12 Times in 8 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Checked the code it was throwing and it said it was the turbo. Taking it in tomorrow so will see what they say!
rstarr harley is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome