Turbo Squeal Between 20 & 30 PSI? - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 03-19-2010, 07:27 AM Thread Starter
fpo
Powerstroke.org Rookie
 
Join Date: Sep 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Turbo Squeal Between 20 & 30 PSI?

All,

My 2008 F250 XLT with Spartan 275 & DPF/DOC Delete just started to squeal from the turbo at 20-30 PSI. It is somewhat finicky, in that it gets worse if I "ease" into the boost to that level. If I stomp on it the sound is negligble or even non existent. Anyone have any ideas before I put my stock equipment back on and take it in? It has 53000 miles currently. I got a "Turbo/Super Charger System Not Functioning Correctly" code one time and it has never come back.

Thank You!
fpo is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 03-19-2010, 02:17 PM
Compression Ignition Addict
 
dieselkane's Avatar
 
Join Date: Oct 2007
Location: Pocat-hell-hole, Idaho
Posts: 1,509
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Exhaust leak at up-pipe??

Traded.. 03 6.0 PSD
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
For.. Black F250 2008 SD LARIAT 6.4 PSD 4x4, Aries Bull Bar, Westin chrome running bars, Dura Liner, B&W Gooseneck hitch, Recon smoked taillights, Icon 4.5" lift, 35" Toyo M/T, etc... Running Spartan Tunes
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
AFE PG 7, Flo Pro 4" DP Back, thanks to Cobb's Diesel. It has been great so far.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Quote:
Originally Posted by azkcr View Post
So all that work and you're keeping the trash can of doom on the exhaust?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dieselkane is offline  
post #3 of 3 Old 03-19-2010, 09:47 PM
Compression Ignition Addict
 
miles97's Avatar
 
Join Date: Oct 2008
Location: western wyoming
Posts: 227
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Check for a ripped boost tube. The one to more than likely fail is the lower driver's side on the cooler.
I have also seen the gasket that goes between the two EGR coolers leak.

97' F250 7.3 XCSB Standard 203,500 miles
T&S 6 position, Sraight piped, K&N
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
SOLD

05' F350 6.0 CCSB Auto 155,000 miles
Edge Platnium W/hot, 4" Sidepipes, AFE intake, leveling lift 325/65R18
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


00' Camaro SS 6-speed standardT-tops 73,000 miles
SLP Airbox SLP loudmouth exhuast custom tuned
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


73' F100 SCLB Standard ? miles
Built 390, lockers, 7" lift, 35 12.50R15
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
miles97 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome