P0087 problem!!!! any ideas - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-14-2010, 10:52 PM
Premium Member
 

Join Date: Feb 2009
Posts: 259
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
P0087 problem!!!! any ideas

My truck has been at ford for about 5 weeks total. It was at Ford for 4 weeks the first time and has been there a week this time.

I took it into the shop and they replaced the HPFP because they said it was bad. The code shows up as Fuel Pressure Sytem to Low. It drove fine for 2 weeks. The problem with it is when it goes into REGEN at highway speeds, I lose tremendous amount of power. If I slow down I will not be able to regain speeds. I have to cut off the truck to be able to get my power back.

The second time I took it into the shop Ford told them to replace a sensor that is under the valve cover. I got 20 miles down the HWY it happend again. I got the P0087 code again. I took it back to Ford and they have checked all the wiring they can without removing the cab. They checked fuel quality and it was fine. They also checked my fuel filters and said those looked good too.

I was just wondering if any of you guys might have an idea I can give the mechanic. I need my truck to go to work and I am desperate to get on the road again. Any help would be great.

I get no other codes.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-21-2010, 02:50 PM
Premium Member
 

Join Date: Feb 2009
Posts: 259
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well guys, I just want to let you know I figured out the problem by reading some of the post here. I knew it prolly wasnt the HPFP since it was 2 weeks old. They changed out the sensors and also the wiring harness. The truck still was not fixed. I would get 20 miles down the road and the check engine light would come on P0087

I read a post on here that said he got that code and he changed his fuel filters. Well, I did that and drained my water sperator and my check engine light cuts off. I took it on the interstate and drove it at 80 mph for 120 miles and my check engine light never cme back on. I think this is the fix.

What make it so bad is that I asked if the tech checked my fuel filters and he said, yeah, everythig is fine. I have had my truck in and out at ford since Dec 20 for a Fuel Filter.

Anyway thanks guys, although nobody posted here, I still found the answere on this site.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:11 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors