Regen Problems.... - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 02-04-2010, 12:21 AM Thread Starter
Compression Ignition Addict
 
drifterdawg's Avatar
 
Join Date: Feb 2009
Posts: 259
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Regen Problems....

Hello all. My truck is having problems in and around the time it goes into regen mode. I was wondering if anyone knew what might be wrong.

1st, It was going into regen mode and would never come out. I would have to pull over and ut the truck off to get it out of regen mode. I would start losing power after about 10 min. I took it to Ford and they replace the high pressure fuel pump. It ran good for about 2 weeks.

2nd, Now it seems to have a problem going in to regen mode. It use to just go into regen mode. Now it tells me to drive to clean for about 5 min (while I am driving) and then it goes into regen mode. Sometimes it comes out and sometime it doesnt. I am still losing power when it will not come out. I am not talking about the slight loss of power that is normal for regen mode. I am talking about not being able to speed up at all from current speeds and if I slow down I will not be able to speed up.

Any help would be nice.

2008 F350 6.4 4x4 dually 30 miles CATV Bucket Truck 4.10 gears. Automatic.
drifterdawg is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 02-04-2010, 05:53 AM
Powerstroke.org Sponsor

 
greasltn's Avatar
 
Join Date: Jan 2009
Location: Hillsborough, NC
Posts: 1,011
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Your pressure sensor in the exhaust may be going south. If you do the DPF delete it should take care of all the problems.

-John
Rudy's Diesel Performance - 919-383-9300 - Diesel Tech


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
greasltn is offline  
post #3 of 5 Old 02-05-2010, 11:52 PM Thread Starter
Compression Ignition Addict
 
drifterdawg's Avatar
 
Join Date: Feb 2009
Posts: 259
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Thank you, Ford seems to think its a sensor this time too. I will let you know what I find out.

2008 F350 6.4 4x4 dually 30 miles CATV Bucket Truck 4.10 gears. Automatic.
drifterdawg is offline  
post #4 of 5 Old 02-08-2010, 06:34 PM Thread Starter
Compression Ignition Addict
 
drifterdawg's Avatar
 
Join Date: Feb 2009
Posts: 259
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Ok, Ford replaced the sensor. It was under the valve covers. I get 35 miles down the road and as soon as it was time for it to go into Regen mode it kicks me out of cruise control and I start losing power again. I did a code search and the code is P0087, fuel rail system, pressure too low. Thats the same code Ive been throwing this whole time.

Any help would be appreciated. They have already replaced the high pressure fuel pump I believe.

2008 F350 6.4 4x4 dually 30 miles CATV Bucket Truck 4.10 gears. Automatic.
drifterdawg is offline  
post #5 of 5 Old 02-04-2013, 05:54 PM
Powerstroke.org Rookie
 
Join Date: Feb 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by drifterdawg View Post
Ok, Ford replaced the sensor. It was under the valve covers. I get 35 miles down the road and as soon as it was time for it to go into Regen mode it kicks me out of cruise control and I start losing power again. I did a code search and the code is P0087, fuel rail system, pressure too low. Thats the same code Ive been throwing this whole time.

Any help would be appreciated. They have already replaced the high pressure fuel pump I believe.
have it hooked up to a computer, make sure the adaptive parameters are reset. mine bout drove me crazy trying to figure it out
4321buff is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome