loss of boost - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-19-2010, 04:29 AM
Powerstroke.org Rookie
 

Join Date: Jan 2009
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
loss of boost

Okay guys,
Normal boost numbers for me with the 275 and delete are about 15 to 19 at 80 mph. Yesterday I noticed that the whooshing sound I usually get when the torque converter locks up was not nearly as loud as usual and now my boost is only about 7 to 9 at 75 or 80 mph. Anyone know what could be going on? I haven't lost any coolant and just a quick visual noticed nothing out of the ordinary. I still can see 25 or 30 psi taking off without going WOT although I have seen 55 or so in the past.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-23-2010, 11:52 AM
Powerstroke.org Rookie
 

Join Date: Feb 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Check your clamp coming off the bottom of the intercooler under the front bumber. Mine broke and came off.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:34 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors