My EGR valve is sticking...now what? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-22-2009, 09:04 PM
Powerstroke.org Rookie
 

Join Date: May 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My EGR valve is sticking...now what?

I need help. I have almost 40,000 miles on Spartan's 250 tune and my EGR valve is now sticking, regardless of what tune I run.
At least I hope it's the EGR valve. I'll cold start it, everything is fine, builds boost as usual, then boost will randomly drop to 10-20psi with corresponding drop in power (difficult to reach 50mph at full throttle). No CELs and no other issues.
Has anyone cleaned their EGR valve?
Thanks in advance guys.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-23-2009, 05:48 AM
Emergency Services

 

Join Date: Apr 2008
Location: Beeville, TX
Posts: 1,483
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Could be a number of things. It might be your high pressure fuel pump.
Reply With Quote Quick reply to this message
  #3  
Old 12-23-2009, 06:27 AM
Compression Ignition Addict
 

Join Date: Mar 2008
Location: Riverside,So-Cal
Posts: 299
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yea, easy to clean on a 04 at least. Do a search on here.
Reply With Quote Quick reply to this message
  #4  
Old 12-23-2009, 08:46 AM
Powerstroke.org Sponsor



 

Join Date: Dec 2008
Location: Georgia
Posts: 8,615
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
You can monitor your EGR valve. The parameter is Commanded EGR under the Generic OBDII paramters. You should not be losing boost if your EGR valve is sticking with the 250 tune. That tune is only supposed to cycle the valve at idle, which means it is ALWAYS closed while driving. If you are losing boost while driving, it sounds like to me that the EGR valve is hanging open while your driving or its something else not even EGR related. Monitor it and see what happens.
Reply With Quote Quick reply to this message
  #5  
Old 12-24-2009, 11:56 AM
Powerstroke.org Rookie
 

Join Date: May 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks 08stroker. I hope its only the valve. I'll try that.

Has anyone tried cleaning their egr valve?
Reply With Quote Quick reply to this message
  #6  
Old 12-26-2009, 09:41 PM
Compression Ignition Addict
 

Join Date: Oct 2008
Location: western wyoming
Posts: 222
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Egr valves on the 6.4's are a major PITA to remove. Even the Rotunda tool sent out by Ford will not remove it most of the time, tool breaks. The best way is to remove the whole air-horn and heat the aluminium up a LITTLE, around the valve to release it. Also try carb cleaner to brake the carbon loose.
Most time need to use force to remove and valve gets messed-up.

VALVE IS COVERED UNDER THE 5YR 100,000 MILES WARRANTY
Reply With Quote Quick reply to this message
  #7  
Old 01-14-2010, 06:09 PM
Powerstroke.org Rookie
 

Join Date: Jan 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My 08 F-550

I have an 08 F-550 that has spent most of it's life in the Shop. Radiators, E.G.R. coolers, This and That and this and that. Today it was towed back for what sounds like your problem barely gets to 50 M.P.H. no power at all boost will not get over 10 P.S.I. Mechanic put on a new fuel pump, Back pressure sensor( that didn't work ) pulling tranny tomorrow to replace some kinda H pipe with a sensor in it. I think next year I will own a Cummins.
Reply With Quote Quick reply to this message
  #8  
Old 01-15-2010, 09:00 AM
Powerstroke.org Sponsor

 

Join Date: Jan 2009
Location: Hillsborough, NC
Posts: 1,011
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Look at all the boots for your IC pipes. Also look at the fuel cooler, it has an elbow that connects the 2 turbos together and the bolts that hold it to the valve cover sometimes back off.
Reply With Quote Quick reply to this message
  #9  
Old 01-15-2010, 02:00 PM
<<< 6.4 Powersmoke
 

Join Date: Oct 2007
Location: Pocat-hell-hole, Idaho
Posts: 1,509
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by BrianR View Post
I need help. I have almost 40,000 miles on Spartan's 250 tune and my EGR valve is now sticking, regardless of what tune I run.
At least I hope it's the EGR valve. I'll cold start it, everything is fine, builds boost as usual, then boost will randomly drop to 10-20psi with corresponding drop in power (difficult to reach 50mph at full throttle). No CELs and no other issues.
Has anyone cleaned their EGR valve?
Thanks in advance guys.
What ended up being your problem?
Reply With Quote Quick reply to this message
  #10  
Old 01-19-2010, 03:31 AM
Powerstroke.org Rookie
 

Join Date: Oct 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Same problem, back to the dealership. I will post with their solution. This came on out of the blue. I had error codes UO100, UO115, UO104. I don't care, the truck was sitting for three days and out of the blue this happens. 26K miles and in the shop twice. I'm beginning to believe the old saying Fix or Repair Daily.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:06 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors