Loss of power? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 12-07-2009, 03:15 PM Thread Starter
Compression Ignition Addict
Join Date: Aug 2009
Location: Abilene,Tx.
Posts: 507
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Loss of power?

This morning I went out and started my truck for it to warm up a few and when I went to take off it had no power and would'nt shift. It seemed to idle fine just no go when I hit the pedel. It did'nt throw any codes or check engine light. I drove it a mile or two to the dealership and took the advisor for and ride so he could get an idea and we pulled over and he restarted the truck and all was good. He said to watch it a few days and see if it happens again. What could it be? My H&S BlackMaxx and DPF/DOC delete is in the mail as we speak and my dealer is not mod-friendly. Should I install it or wait a while? Could this be just a freak type of thing? Thanks in advance guys.

2011 GMC CC/SB Z71 SLE LML/Allison
:SOLD: 2008 F-250 6.4/12.906@104.42MPH 1/4
08TWIN6.4L is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome