Mirror turn signals - Ford Powerstroke Diesel Forum
6.4 Exterior Discussion Body and Accessories Talk

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-29-2013, 02:53 PM
Serving Our Country!
 

Join Date: May 2011
Posts: 164
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mirror turn signals

My mirror turn signals quit working. The marker lights still work but no turn signals. I changed the bulbs but still no turn signal. There isn't a fuse listed in the owners manual for the mirror turn signal. I'm stumped.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-29-2013, 07:53 PM
Compression Ignition Addict
 

Join Date: Feb 2011
Location: Brighton, CO
Posts: 249
Thanks: 5
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Try taking the bulb out and rotating it 180* if its not in the correct way they won't work. I had the same problem.
Reply With Quote Quick reply to this message
  #3  
Old 01-30-2013, 04:18 AM
Serving Our Country!
 

Join Date: May 2011
Posts: 164
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I tried that. They don't have anything to do with the trailer plug do they? I got rear ended a few weeks ago and just got the truck back from the body shop.
Reply With Quote Quick reply to this message
  #4  
Old 01-30-2013, 04:45 AM
Premium Member

 

Join Date: Oct 2010
Location: South Jersey
Posts: 400
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Mine quit working so I did the smoked lens recon swap out with LED's and the turn signals work again. I did notice something while installing the recon lights I did not plug the bulb harness in correctly and the signals weren't working. I just flipped the connection around and the turn signals worked fine.
Reply With Quote Quick reply to this message
  #5  
Old 01-30-2013, 06:47 AM
Compression Ignition Addict
 

Join Date: Feb 2011
Location: Brighton, CO
Posts: 249
Thanks: 5
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
If flipping the connection didn't work I would get a volt meter and check to make sure you are getting power to the bulbs. Or possibly try new bulbs. I don't think the being rear ended would cause that, but crazier things have been known to happen with these trucks.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:29 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors