TBC " wiring fault on trailer " error - Ford Powerstroke Diesel Forum
6.4 Electronics Discussion TV's, Radios, everything electric and NON-Performance.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-13-2014, 01:12 PM
Powerstroke.org Rookie
 

Join Date: Oct 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
TBC " wiring fault on trailer " error

Hello I have this fault on my dash. I checked all fuses and there good. I have power on all of the 7 and 4 connectors on the plugs when activated so no problem there. Having searched on here it sounds like most people say it's water or corrosion on the plug so I pulled that and there is no corrosion and it was stuffed with die-electric grease. I'm wondering what others have done to fix this? Some have replaced plug but I hate to waste $30 if that's not going to fix the problem. what else can I check/try to fix this. Or if you've had this what did you do to fix it that worked?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-15-2014, 01:26 PM
Powerstroke.org Rookie
 

Join Date: Oct 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Nobody has had this problem? Even if you had this problem fixed under warranty I'd like to know what took care of it.
Reply With Quote Quick reply to this message
  #3  
Old 03-15-2014, 01:50 PM
Compression Ignition Addict
 

Join Date: Apr 2011
Location: Calgary, Alberta Canada
Posts: 1,294
Thanks: 0
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
I had the error come up once and I just unplugged the trailer and then plugged it back in and it went away. I'm guessing it was just a bad connection or something. Seems like factory brake controllers on any trucks are problematic.
Reply With Quote Quick reply to this message
  #4  
Old 03-16-2014, 05:13 PM
Powerstroke.org Rookie
 

Join Date: Oct 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks Alberta but mine is doing this with no trailer connected. Which means it's something truck related I think I'm going to just buy a new plug for the rear and see if that takes care of the problem.
Reply With Quote Quick reply to this message
  #5  
Old 03-20-2014, 05:16 PM
Member
 

Join Date: Jan 2014
Posts: 84
Thanks: 1
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Hey pointman I can pm you a pin out test for the fault. Some of it requires the IDS but there are some tests you should be able to do yourself if that would help.

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #6  
Old 03-20-2014, 07:51 PM
Powerstroke.org Rookie
 

Join Date: Oct 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
jcook sounds good I don't have IDS would a snap on modis be able to test for anything? otherwise I'd have to take it to the dealer and that's $95 minimum. Send me what you have and hopefully it will help me get this figured out. thanks
Reply With Quote Quick reply to this message
  #7  
Old 03-22-2014, 03:35 PM
Powerstroke.org Rookie
 

Join Date: Mar 2007
Location: Pocomoke, Maryland
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have had the same code. Mine had water inside the 7 pin connecter housing. I took it apart and cleaned it with electrical cleaner. The fault never came back until last week when I was power washing the underside. Opened the housing up again...full of water.Cleaned it again, code gone. I could still tow with no issues with the trailer.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:08 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors