electric questions - Ford Powerstroke Diesel Forum
6.4 Electronics Discussion TV's, Radios, everything electric and NON-Performance.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-04-2013, 10:28 AM Thread Starter
Powerstroke.org Rookie
Join Date: Aug 2013
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
electric questions

Two things bought my truck used couple weeks ago 08 F350 crewcab long bed and reverse lights aren't working need to know which wire is reverse signal to hookup back up camera...also how do I know if the truck has backup sensors?

lastly my enclosed trailer has 2 12v interior lights that are not working. on my 05 F150 all I did was add a fuse to the fuse panel and the lights worked...anyone know if this is the same issue on the PSD? if so which panal on the fuse block takes the fuse to power the interior lights on the trailer.

Thanks in advance.
houtxf350 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome