Mirror turn signal not working - Ford Powerstroke Diesel Forum

6.4 Electronics Discussion TV's, Radios, everything electric and NON-Performance.

 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 08-01-2013, 03:12 PM Thread Starter
Compression Ignition Addict
 
preston77's Avatar
 
Join Date: Nov 2010
Location: New Orleans
Posts: 160
Thanks: 2
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Mirror turn signal not working

Neither turn signal on the mirrors work. Bulb is fine, tried the aftermarket led's, switched the polarity on the led's and nothing. Can't find anything in the owners manual on a fuse for them either. Thanks in advance, Preston

preston77 is offline  
post #2 of 10 Old 08-10-2013, 03:48 AM Thread Starter
Compression Ignition Addict
 
preston77's Avatar
 
Join Date: Nov 2010
Location: New Orleans
Posts: 160
Thanks: 2
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Bump......

preston77 is offline  
post #3 of 10 Old 08-17-2013, 04:33 PM
Compression Ignition Addict
 
ynpmoose's Avatar
 
Join Date: Jul 2013
Location: Centerport, PA
Posts: 351
Thanks: 8
Thanked 22 Times in 17 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
I looked at the 2008 wiring diagram and fuse layout. Check fuse #21 - 15Amp (Fog lamp relay feed, Cornering lamps). It looks like a single fuse does both mirrors.

Moose

2003 Excursion 6.0L 4x4 (w/o rear HVAC)
Insight CTS w/ EGT probe/fuel pressure/coolant pressure/Backup camera
Gearhead SRL tune w/ SCT x4 | Ed's FICM + PHP Eco | River City EGR Delete | Blue spring | DC Power 185
Rotella T6 + Archoil | Optilube XPD | Zerex ELC and DFUser Coolant filter
Hankook Dynapro ATM RF10 | Silverstar ZXE | Excursion high idle mod | Viper Remote Start
ynpmoose is offline  
post #4 of 10 Old 08-20-2013, 04:20 PM Thread Starter
Compression Ignition Addict
 
preston77's Avatar
 
Join Date: Nov 2010
Location: New Orleans
Posts: 160
Thanks: 2
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Negative on #21 ghost rider, but thanks.

preston77 is offline  
post #5 of 10 Old 01-16-2014, 11:30 AM
Powerstroke.org Rookie
 
bullfighter1777's Avatar
 
Join Date: May 2007
Location: kerr county, texas
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
did you figure out the problem? my 2010 kr has same problem.

I check the fuses as well as chanding out bulbs. the mirror marker lights work fine but the turn signal lights on both sides are not working at all. any help?

BULLFIGHTER1777
bullfighter1777 is offline  
post #6 of 10 Old 01-16-2014, 11:59 AM
Compression Ignition Addict
 
jse51599's Avatar
 
Join Date: Dec 2010
Location: St. Charles, MO
Posts: 1,135
Thanks: 1
Thanked 5 Times in 5 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I have a similar problem with my mirrors... on mine the parking lights don't work, but the signals do. My problem is the wiring in the loom between the door and the cab. Apparently, one of them pinched and I can get them to come on by moving the loom around. Obviously not the same truck or exact problem, but maybe it's a place to look if you haven't already.....

6637, Diamond Eye Turbo Back, Riffraff Billet Intake Plenums and Intercooler Boots, WW2, Deleted EBPV
305 70 16 Toyo A/T IIs


Jim



jse51599 is offline  
post #7 of 10 Old 01-17-2014, 04:12 AM Thread Starter
Compression Ignition Addict
 
preston77's Avatar
 
Join Date: Nov 2010
Location: New Orleans
Posts: 160
Thanks: 2
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I haven't figured it out still, I kinda just gave up lol.

preston77 is offline  
post #8 of 10 Old 01-17-2014, 04:17 AM
Member
 
Join Date: Jan 2014
Posts: 33
Thanks: 1
Thanked 3 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Well at least I'm not the only one with this problem. I've seen several trucks around town with the same problem too.

06-f250 KR
FawlGuy is offline  
post #9 of 10 Old 01-17-2014, 12:16 PM
Powerstroke.org Rookie
 
bullfighter1777's Avatar
 
Join Date: May 2007
Location: kerr county, texas
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
ok< ill check the wiring around door jam tonight. my truck is still under warranty, should i take in for them to mess with it?

BULLFIGHTER1777
bullfighter1777 is offline  
post #10 of 10 Old 01-17-2014, 02:09 PM
Compression Ignition Addict
 
jse51599's Avatar
 
Join Date: Dec 2010
Location: St. Charles, MO
Posts: 1,135
Thanks: 1
Thanked 5 Times in 5 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
As long as you double check fuses and bulbs. I took a car in for service one time for power windows not working and came out with an $80 charge to replace a blown fuse....

Sent from AutoGuide.com Free App

6637, Diamond Eye Turbo Back, Riffraff Billet Intake Plenums and Intercooler Boots, WW2, Deleted EBPV
305 70 16 Toyo A/T IIs


Jim



jse51599 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome