Rigid Dually D2 Fogs Wiring Problem - Ford Powerstroke Diesel Forum
6.4 Electronics Discussion TV's, Radios, everything electric and NON-Performance.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-04-2012, 06:36 PM Thread Starter
Powerstroke.org Rookie
Join Date: Aug 2008
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Rigid Dually D2 Fogs Wiring Problem

Okay, I suck at anything electrical but I thought I'd try to wire D2's in myself.

Fabricating brackets to install the lights were no problem. I ended up cutting out the relay from the wiring harness from Rigid. The wiring is as follows.

From the lights come a pair of red and black wires. The red wire from this pair, i connected to upfitter 1. There was another pair of red and black wires. These wires I connected to the positive (red wire) and negative (black wire) terminals of my battery. I soldered the loose ends of the two black wires together and connected to the frame of the truck. The red wire connected to the battery has a 15 amp fuse and I currently have the other end loose - with a cap.

My problem is, THE LIGHTS WORK!!!! I have no idea why or how. Can any one tell me what I did wrong? I know my fuse is useless and don't want to short the electrical system, but where is the power coming from?

Any help would be appreciated.
Canada0937 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome