Hid light problem - Ford Powerstroke Diesel Forum
6.4 Electronics Discussion TV's, Radios, everything electric and NON-Performance.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 3 Old 07-31-2012, 06:34 AM Thread Starter
Powerstroke.org Rookie
Join Date: Jul 2012
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hid light problem

Hid headlight problem
Hi everyone, I'm new here and new to the ford family, I have a 09 f350 Harley, here's my problem, when I bought the truck it had hid in it, then passenger headlight went out, check bulb ok, figured it was the ballast, so I bought a new hid headlight kit, installed it, it works sometimes, seems when truck first fires up they work, then after a few min of driving it goes out, but I also noticed, sometimes when the head light works the fog light don't, and then fog light does and head light don't and sometimes both.. Any ideas it would greatly be appreciated
Cowboyup007 is offline  
Sponsored Links
post #2 of 3 Old 08-04-2012, 04:29 AM
Compression Ignition Addict

tony97gt's Avatar
Join Date: May 2012
Location: Broward County
Posts: 644
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 5
Thanked 4 Times in 3 Posts
Feedback Score: 1 reviews
Check with the manufacturer/distributor where you bought the HID kit. You may need a relay harness.

2008 F250 Harley Davidson 4x4, Upgraded LED lighting, JL Audio 13.5" Stealthbox, JL Audio C3 door speakers, JL Audio 500.1 for the stealthbox, JL Audio 400.4 for the doors, Viper 5704 alarm/SmartStart and GPS tracker, JimmiJammer door plates, JimmiJammer gateguard, Delete front lock/rear handle swap, DPF delete, MiniMaxx, 2.5" level, Sinister coolant filter, 55w 6000k HID's driving/fog lights, S+B CAI, MBRP 5" DP back exhaust, 35x12.5x20 TIS 20" rims, Nitto Trail Grapplers, adjustable track bar.
tony97gt is offline  
post #3 of 3 Old 08-04-2012, 10:50 PM
Compression Ignition Addict
Alberta Advantage's Avatar
Join Date: Apr 2011
Location: Calgary, Alberta Canada
Posts: 1,476
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 4
Thanked 24 Times in 23 Posts
Feedback Score: 0 reviews
HIDs are notorious for these issues. I have the same problems with mine. Doesn't matter if it's winter or summer, the passenger side won't always illuminate. Have changed the ballast, bulb, and added a relay. Still the same issue. It's inconsistent and a crap shoot whether it will work or not. When I get Harley headlights on my truck, I'm just going to get some Piaa halogens. Apparently, they're a pretty close match although not identical in color to an HID but at least, I won't have one headlight not working. Don't know what's up with your fog lights though.

09 F350 CCSB SRW Cabela's.

Husky Weather Beaters
Putco Window Visors
Piaa Xtreme White 4k
Dura Flap SS Mud Flaps
Recon Smoked Mirror, Brake, Tails
Bak Flip F1
Bilstein Dual Steering Stabilizer
Bilstein 5100
Nitto Terra Grapplers
Firestone Air Bags
Air Horn
PMF HD Draglink/Trackbar
Vision X Lights
2" Solstice Solo
8" Evo Prime
12" XMitter Low Pro Prime
4" Solstice Prime
20" Evo Prime Double Stack
12" XMitter Prime Ambers
Truck Bed Lights
Alberta Advantage is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome