Bought a 6.4 today & cruise doesnt work! - Ford Powerstroke Diesel Forum
6.4 Electronics Discussion TV's, Radios, everything electric and NON-Performance.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 08-05-2011, 09:57 PM Thread Starter
Powerstroke.org Rookie
 
wifordboyee's Avatar
 
Join Date: Aug 2011
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bought a 6.4 today & cruise doesnt work!

I bought a 2008 6.4 F250 today and now discovered the cruise control does not work! also the front right turn signal and glow plugs dont work! what might be the problem and/or fix??
wifordboyee is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 08-05-2011, 10:05 PM
Compression Ignition Addict
 
..::ryan::..'s Avatar
 
Join Date: Mar 2010
Location: San Antonio, TX
Posts: 332
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
All your glow plugs don't work?
..::ryan::.. is offline  
post #3 of 8 Old 08-06-2011, 07:06 AM Thread Starter
Powerstroke.org Rookie
 
wifordboyee's Avatar
 
Join Date: Aug 2011
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
By glow plugs I mean preheater! Like when you turn the key before you start it there's a light that comes on saying its preheating! That doesn't work
wifordboyee is offline  
post #4 of 8 Old 08-07-2011, 09:58 AM
Member
 
Join Date: Jul 2011
Location: Corpus Christi, TX
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well....there could be several explanations.

First off, you said you just bought this truck. Are you sure you know how to use the cruise control? Press the ON button and then press the SET button.

Second. The turn signal could just need a bulb replaced.

Third. You should NEVER see a 6.4 glow plug light come on unless it is extremely cold outside. I live in Texas and it has never been cold enough for my light to come on.

2008 F-250 SC SRW 4X4
H&S Mini Maxx - DPF Delete - S&B - Dieselsite Coolant Filter
08F250TX is offline  
post #5 of 8 Old 08-07-2011, 10:23 AM Thread Starter
Powerstroke.org Rookie
 
wifordboyee's Avatar
 
Join Date: Aug 2011
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well the glow plugs are fine! my dads 6.0 ALWAYS comes on but mine doesnt come on unless it sits for a while and then it only comes on for a sec!
but the cruise is still not working and i DO KNOW how to operate it! theres a lil white box under the dash- speed wizard- not sure what its for or if thats messing up the cruise! btw the truck is riding on 40s soo could it be to calibrate the tire size!? someone said aftermarket cruise controll????
wifordboyee is offline  
post #6 of 8 Old 08-07-2011, 10:24 AM Thread Starter
Powerstroke.org Rookie
 
wifordboyee's Avatar
 
Join Date: Aug 2011
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
and the turn signal is a wiring prob i think! someon was def ******* with the wiring previously
wifordboyee is offline  
post #7 of 8 Old 08-07-2011, 10:32 AM
Powerstroke.org Fanatic
 
spideygsm's Avatar
 
Join Date: Apr 2011
Posts: 131
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Spend a couple of bucks and change out all of the bulbs before you start tinkering with the wiring. The truck is 3-years old.

Welcome to the world of the 6.4's

SOLD F350 XLT 6.4L 4x4 FX4, Long Bed
2011 3500 Laraime Longhorn, 6.7L HO, 4x4
2006 6 Cyl 4x2 Toyota Tundra (beater)
Tows 26-foot Tracer, Honda Rancher, YZ450F
Air Force Veteran
spideygsm is offline  
post #8 of 8 Old 08-07-2011, 10:38 AM Thread Starter
Powerstroke.org Rookie
 
wifordboyee's Avatar
 
Join Date: Aug 2011
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Tried a new bulb and that's not the prob!
wifordboyee is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome