Bought a 6.4 today & cruise doesnt work! - Ford Powerstroke Diesel Forum
6.4 Electronics Discussion TV's, Radios, everything electric and NON-Performance.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-05-2011, 08:57 PM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bought a 6.4 today & cruise doesnt work!

I bought a 2008 6.4 F250 today and now discovered the cruise control does not work! also the front right turn signal and glow plugs dont work! what might be the problem and/or fix??
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-05-2011, 09:05 PM
Compression Ignition Addict
 

Join Date: Mar 2010
Location: San Antonio, TX
Posts: 323
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
All your glow plugs don't work?
Reply With Quote Quick reply to this message
  #3  
Old 08-06-2011, 06:06 AM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
By glow plugs I mean preheater! Like when you turn the key before you start it there's a light that comes on saying its preheating! That doesn't work
Reply With Quote Quick reply to this message
  #4  
Old 08-07-2011, 08:58 AM
Member
 

Join Date: Jul 2011
Location: Corpus Christi, TX
Posts: 63
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well....there could be several explanations.

First off, you said you just bought this truck. Are you sure you know how to use the cruise control? Press the ON button and then press the SET button.

Second. The turn signal could just need a bulb replaced.

Third. You should NEVER see a 6.4 glow plug light come on unless it is extremely cold outside. I live in Texas and it has never been cold enough for my light to come on.
Reply With Quote Quick reply to this message
  #5  
Old 08-07-2011, 09:23 AM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well the glow plugs are fine! my dads 6.0 ALWAYS comes on but mine doesnt come on unless it sits for a while and then it only comes on for a sec!
but the cruise is still not working and i DO KNOW how to operate it! theres a lil white box under the dash- speed wizard- not sure what its for or if thats messing up the cruise! btw the truck is riding on 40s soo could it be to calibrate the tire size!? someone said aftermarket cruise controll????
Reply With Quote Quick reply to this message
  #6  
Old 08-07-2011, 09:24 AM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
and the turn signal is a wiring prob i think! someon was def ******* with the wiring previously
Reply With Quote Quick reply to this message
  #7  
Old 08-07-2011, 09:32 AM
Powerstroke.org Fanatic
 

Join Date: Apr 2011
Posts: 131
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Spend a couple of bucks and change out all of the bulbs before you start tinkering with the wiring. The truck is 3-years old.

Welcome to the world of the 6.4's
Reply With Quote Quick reply to this message
  #8  
Old 08-07-2011, 09:38 AM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Tried a new bulb and that's not the prob!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:16 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors