Trailer Lights not working - Ford Powerstroke Diesel Forum
6.4 Electronics Discussion TV's, Radios, everything electric and NON-Performance.

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 06-30-2011, 08:59 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2010
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Trailer Lights not working

I am having an issue with my trailer lights. I know the lights on the trailer are good because they were working before and i have tried with multiple trailers. The lights on the trailer(all of them) just stay on constantly. The blinkers, the running lights, and the brake lights are all on. Someone told me it could be a fuse. I looked in the manual and found out that there are seperate fuses on the truck just for the trailer lights. I havent had a chance to look in to those yet.

Any one else have this issue? Any help would be great.

2010 Diesel KR w/ a Ranch Hand FER
10DieselKR is offline  
post #2 of 7 Old 06-30-2011, 09:11 AM
Super Moderator


 
SuperCrutyPS's Avatar
 
Join Date: Jul 2008
Location: Orangevale, CA
Posts: 15,254
Thanks: 82
Thanked 491 Times in 475 Posts
Mentioned: 4 Post(s)
Quoted: 258 Post(s)
Garage
Feedback Score: 0 reviews
A couple of questions.

Are you using the 4-pin or the 7pin connector?
Any trailer you put on your truck does the same thing?


Owner | Operator: Darryl
My Truck Garage: Ol' Guy
Tow Toy Garage : Pilgrim International 31RE3SLF5
United States Navy - IC2 - '76-'80
SuperCrutyPS is offline  
post #3 of 7 Old 06-30-2011, 09:22 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2010
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I am using the 4 pin. I havent tried another truck, but i plan to this weekend. It is just weird.

2010 Diesel KR w/ a Ranch Hand FER
10DieselKR is offline  
post #4 of 7 Old 06-30-2011, 09:32 AM
Super Moderator


 
SuperCrutyPS's Avatar
 
Join Date: Jul 2008
Location: Orangevale, CA
Posts: 15,254
Thanks: 82
Thanked 491 Times in 475 Posts
Mentioned: 4 Post(s)
Quoted: 258 Post(s)
Garage
Feedback Score: 0 reviews
If you have a volt meter, check to see if you have power on all the 'power' pins to ground. Since you are there, check the 7-pin also. This could tell you that you might have a short somewhere.


Owner | Operator: Darryl
My Truck Garage: Ol' Guy
Tow Toy Garage : Pilgrim International 31RE3SLF5
United States Navy - IC2 - '76-'80
SuperCrutyPS is offline  
post #5 of 7 Old 06-30-2011, 09:35 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2010
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Yeah, i was going to try that too. They make a little 4 pin tester thats like $5 that you plug in and it has leds that tell you what has power and what doesnt. I am planning on picking one of those up today.

2010 Diesel KR w/ a Ranch Hand FER
10DieselKR is offline  
post #6 of 7 Old 01-03-2012, 07:26 AM
Powerstroke.org Rookie
 
Join Date: Jan 2010
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Trailer lights have a Fuse (under hood)
shinertk is offline  
post #7 of 7 Old 01-03-2012, 12:08 PM
Serving Our Country!

 
f250ghost's Avatar
 
Join Date: Oct 2007
Location: Navarre, FL
Posts: 2,513
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Send a message via AIM to f250ghost Send a message via MSN to f250ghost Send a message via Yahoo to f250ghost
I had a similar issue...only I would only get turn signals and brake lights...no running lights. Pin checked it and the running light pin (on both connectors) wasn't getting any power. Took it to Ford this morning (truck still under warranty) and they said they put an emulator on it and the plug works fine. Anyway...checked the fuses and the fuse was blown..turns out the dealership didn't know what the "F" they were talkin about.

Hope you get yours fixed man!

-Ben
2006 F250 FX4
6.0 PowerStroke
Panhandle PowerStrokes Director

Last edited by f250ghost; 01-03-2012 at 01:35 PM.
f250ghost is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome