Front hubs wont lock - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 12-06-2013, 11:49 AM Thread Starter
Powerstroke.org Fanatic
 
cbarm's Avatar
 
Join Date: Jun 2013
Posts: 100
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Front hubs wont lock

About a month ago I noticed my front hubs would not lock if I use the switch on the dash, but they will lock in manual mode. Are these electric hubs? Neither one of em work on auto mode, but its fine doing it old skool. Any ideas of what I can check?

2010 F450 King Ranch 6.4L 4x4 4.30 ratio 130K miles bone stock
1994.5 F350 XLT 7.3 PSD ZF5 CC DRW 220K miles
cbarm is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome