4x4 not working, plastic pieces in hubs - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-17-2013, 06:05 AM
Compression Ignition Addict
 

Join Date: May 2009
Location: CT
Posts: 400
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
4x4 not working, plastic pieces in hubs

Last night my 4x4 wouldnt engage when i wanted to do a boosted launch, the hubs wouldnt turn very well either, so i read a little last night and found that it sounded like an easy job to take out and lube up the hubs to make them slide easier and hopefully work properly. I took one out this morning when i got to work to find little plastic pieces inside the hub, anyone have any ideas?

truck is a 2008 f250 with auto hubs and electronic switch
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-02-2013, 08:45 PM
Compression Ignition Addict
 

Join Date: Oct 2012
Location: Texas
Posts: 200
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I know what youre talking about. I have NO idea what they do but when I pulled my hubs to clean them and re grease I found that black plastic cage looking thing had been coming apart. Shiiii! I just cleaned it all out, greased the damn things and popped them back in. Seems to be working fine. I assume you have manual locking front hubs?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:08 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors