Charging light issue - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-18-2009, 10:47 PM
Powerstroke.org Rookie
 

Join Date: Aug 2007
Location: Spring, TX
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Charging light issue

About a month back the battery light started flashing every once in a while, while i was driving. The truck was completely dead on me last weekend in the driveway, so I load tested the batteries last weekend and both batteries were bad. I replaced the batteries and everything had been great until driving home in the rain with all of the lights on, radio, a/c, etc... By the time I was pulling into the driveway an hour later, everything in the truck was dead, doors wouldn't even lock. So i charged the batteries for a good 8 hours this morning to get to a buddies house to change out the alternator.

On the way home the battery light came back on solid for the whole drive. The new alternator was putting out about 13v at idle, and a little over 13.5v at 1500rpm. The same as what the previous alternator was doing. I know the batteries were not fully charged after only 8 hours on the charger.

A few questions....

Could this be a bad alternator?

Will the charge light come on if the alternator is putting out current, but the batteries are still low?

Could this be a wiring / electrical issue, and what should i look for?

thanks,

Jaime
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-18-2009, 11:02 PM
Compression Ignition Addict
 

Join Date: Nov 2008
Location: Versailles ky
Posts: 198
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
when my battery light flased it was my alternator had it rebiult and not a bit of trouble since and I cought it be for it completely drained my battries but if you replace the alternator already I would check for a wire somewere or possibly a fuse
Reply With Quote Quick reply to this message
  #3  
Old 04-18-2009, 11:48 PM
Compression Ignition Addict
 

Join Date: Nov 2007
Posts: 179
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I would like to see about 14.5 volts for the alternator output, maybe the new alt is defective?
Reply With Quote Quick reply to this message
  #4  
Old 04-19-2009, 07:50 AM
Powerstroke.org Rookie
 

Join Date: Aug 2007
Location: Spring, TX
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
is that 14.5v at idle?

Jaime
Reply With Quote Quick reply to this message
  #5  
Old 04-19-2009, 07:55 AM
im fat and ugly


 
Join Date: Aug 2006
Location: Shreveport, LA
Posts: 15,687
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
sounds like what mine did, put a new alternator on and it has worked fine.

but if youve already put a new altenator on im not sure
Reply With Quote Quick reply to this message
  #6  
Old 04-19-2009, 03:59 PM
Powerstroke.org Rookie
 

Join Date: Aug 2007
Location: Spring, TX
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well it looks like the alternator was bad right out of the box. There is an intermittent connection in the regulator.... Remanufactured P.O.S. !!!

J
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:33 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors