'06 with a heckup - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-06-2009, 09:03 AM
Member
 

Join Date: Feb 2008
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
'06 with a heckup

I have an '06 F550, typical cold running problems. My big problem now is that it wants to heckup and blow really deep black smoke out the tail pipe. Does it mainly when cold, I went to move it about 10 feet yesterday and she dyied twice, each time belching out a puff of black smoke. When running down the road, she will start heckuping when above 2000 rpm or just at the point of shifting. Turbo psi. seems to be good, 20-23 at take off, 8-12 at 55 or so, 29-31 pulling a load. I have changed fuel filters and cleaned air cleaner. It is a K & N but I don't use the oil. What could be my problem?
Thanks in advance, Greg
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-06-2009, 01:24 PM
Compression Ignition Addict
 

Join Date: Aug 2007
Posts: 195
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Try and clean your egr valve, my truck did the same as yours. Now I have the egr cooler blocked off.
Reply With Quote Quick reply to this message
  #3  
Old 04-06-2009, 01:43 PM
Member
 

Join Date: Feb 2008
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Where is it located at? I thank I know but not sure. What is an egr cooler block off? Don't know much about the 6.0L.
Reply With Quote Quick reply to this message
  #4  
Old 04-06-2009, 06:24 PM
Compression Ignition Addict
 

Join Date: Aug 2007
Posts: 195
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It sits in front of the oil canister with a plug in the top of it. The uppipe comes off of the exhaust manifold and then y's to the egr cooler, where it y's to the cooler I cut it off and then welded a plate over the uppipe. There is a scoop in the uppipe that restricts exhaust flow, I also cut that out. Blocking the cooler off will prevent the cooler from failing and you dont have to worry about plugging the egr valve. There are other ways to do this, but living in ca. I could not remove the whole cooler since there will be emmisions testing starting in 2010.
Reply With Quote Quick reply to this message
  #5  
Old 04-06-2009, 06:30 PM
Super Moderator

 

Join Date: Nov 2008
Posts: 13,271
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 2 reviews
Could also be a bad injector(s)
Reply With Quote Quick reply to this message
  #6  
Old 04-06-2009, 08:13 PM
Premium Member
 

Join Date: Feb 2007
Location: Wisconsin
Posts: 1,366
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Try the ford reflash if it hasnt had it.
Reply With Quote Quick reply to this message
  #7  
Old 04-07-2009, 06:07 AM
Member
 

Join Date: Feb 2008
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It was reflashed last fall. I got a new egr valve just installed and it runs better but is still stalls out on takeoff. Does take awhile to get all the soot cleaned out of the system so it will run better or is there something else I should do?
Reply With Quote Quick reply to this message
  #8  
Old 04-07-2009, 07:21 AM
Compression Ignition Addict
 

Join Date: Aug 2007
Posts: 195
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
If you are still under warranty I would take it in, and dont forget to put your stock air filter on. There is a thread about ford doing a carbon cleaning, that sounds promissing.
Reply With Quote Quick reply to this message
  #9  
Old 04-07-2009, 08:54 AM
Member
 

Join Date: Feb 2008
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just got on secdule for a cleaning. I have ran the truck for about half an hour loaded and it seems to be getten better. I don't need to worry about the air cleaner, they sell and install the same one I have. They highly reccamend puting one on.
Reply With Quote Quick reply to this message
  #10  
Old 04-21-2009, 10:06 AM
Member
 

Join Date: Feb 2008
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well, fixed the problem. Put on a new EGR valve, cleaned the intake manifold, and put on a new FICM. Runs like a champ now.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:10 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors