NEED HELP - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 04-04-2009, 07:28 PM Thread Starter Rookie
Join Date: Mar 2009
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews

I have a 03, F250 6.0 113K all stock. My problem is when I accelerate to get on the highway or am on the highway going at about 70-75mph and accelerate to pass, my truck starts to buck and throws out a bunch of smoke when it's doing this. I replaced the air cleaner, fuel filters, cleaned the EGR, didn't help. So I took it to the dealer and asked them to pull codes. They came back and said my VGT needed to be replaced along with the TURBO. I also had them do the induction cleaning. I purchased a rebuilt TURBO and got another VGT, installed them myself. AND I STILL HAVE THE SAME PROBLEM. Anyone have any ideas? I will be calling the dealer and see what they will do about it. I feel like they miss diagnosed the problem.
roadking624 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome