6.0 turbo problem!! - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 Old 04-02-2009, 05:37 PM Thread Starter
Member
 
Join Date: Mar 2009
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.0 turbo problem!!

I have an 06 6.0...I was drivinn on the highway and all of the sudden i heard i loud pitched squeal from the engine. It wasnt the sound of the turbo spooling up. I got home and checked a few things out. IT only squeals when the turbo is spooling up. Its so loud it hurts your ears. It is a complete different kind of squeal then the noise the turbe makes when its spooling up. I ran it hard and it started to make the noise when the boost was around 5 and i floored and it boosted up to 20 idk if that is low or not? Any help would be great becasue i was planning on a long trip tomoro.
sobrien1130 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 04-02-2009, 05:40 PM
Compression Ignition Addict
 
BlackPearlF250's Avatar
 
Join Date: Oct 2008
Location: Kingsville,MD
Posts: 338
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to BlackPearlF250
check your hoses/pipes

Black Pearl
2003 F250 SD CC SB 6.0
4" Turbo Back Exhaust
Kitty Delete
Zoodad Mod
AFE Intake
Rhino Liner
Mag-Hytec Deep Trans Pan
Suncoast Trans Cooler
3" Leveling Kit
Shift Kit
SCT - Tunes by Cale
BlackPearlF250 is offline  
post #3 of 12 Old 04-02-2009, 05:48 PM
Compression Ignition Addict
 
ABoyAndHisToys's Avatar
 
Join Date: Feb 2008
Location: Bayville, NJ
Posts: 1,050
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to ABoyAndHisToys
Sounds like a boot to me.

2001 CC Long Bed Fat A$$
New Heart w/Forged Rods @ 108,000miles (Damn PMR's).... with some goodies on it



Brandon

ABoyAndHisToys is offline  
post #4 of 12 Old 04-02-2009, 05:57 PM
back in the saddle

 
shu873's Avatar
 
Join Date: Oct 2006
Location: Tipton, Iowa
Posts: 9,482
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 9
Thanked 10 Times in 7 Posts
Feedback Score: 0 reviews
Check/inspect all your boots connecting the I/C pipes. My bet is you have a split in one of them. You'll most likely have to remove each one for a good inspection unless the problem boot is obvious.

Kurt

shu873@powerstroke.org

'06 True Blue/Silver 250 crew cab
ARP's, EGR blocked
AFE stg.2, MBRP 4" pipe
Air Dog 150, ITP reg. return
Bulletproof oil bypass system
Banks technicooler
Ride rite air springs in the rear
EGT, boost, and fuel pressure gauges by DiProcol on the pillar

Plus a few other odds and ends...
shu873 is offline  
post #5 of 12 Old 04-02-2009, 06:13 PM
PMR = JUNK

 
Jake's Avatar
 
Join Date: Nov 2007
Location: NW, Ohio
Posts: 11,199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Send a message via AIM to Jake Send a message via Yahoo to Jake
Im thinkin coolant res. Head gasket or EGR problem perhaps?

BPS President

2000 F-250, forged rods, 38r turbo, BTS trans, TW tuning and Bad Night Special 50 horse Caterpillar injectors

2002 F-350, remote engine mod



Quote:
Originally Posted by alberta 7.3 View Post
Yeah, I'd probably feel a bit drained after firing twice in rapid succession.
Facebook: Jake Phillips. If you add me tell me who you are.

Jake is offline  
post #6 of 12 Old 04-02-2009, 06:35 PM Thread Starter
Member
 
Join Date: Mar 2009
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What do you mean by the coolant res? does anyone think its the turbo?
sobrien1130 is offline  
post #7 of 12 Old 04-02-2009, 06:47 PM
Premium Member
 
stroken04's Avatar
 
Join Date: Dec 2007
Location: Shawnee, OK
Posts: 4,938
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by sobrien1130 View Post
What do you mean by the coolant res? does anyone think its the turbo?
It could be gas escaping from the degas bottle (coolant res), which points towards head gaskets or EGR issues. Is there a residue on your coolant res, Is it drinking coolant?

I would do as suggested earlier and check the IC boots
stroken04 is offline  
post #8 of 12 Old 04-02-2009, 06:50 PM
back in the saddle

 
shu873's Avatar
 
Join Date: Oct 2006
Location: Tipton, Iowa
Posts: 9,482
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 9
Thanked 10 Times in 7 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Jake View Post
Im thinkin coolant res. Head gasket or EGR problem perhaps?
He described it as an extremely loud screeching noise under boost. When the degas bottle hisses it's noticeable, but shouldn't be so loud in the cab you can't hear yourself think.

Kurt

shu873@powerstroke.org

'06 True Blue/Silver 250 crew cab
ARP's, EGR blocked
AFE stg.2, MBRP 4" pipe
Air Dog 150, ITP reg. return
Bulletproof oil bypass system
Banks technicooler
Ride rite air springs in the rear
EGT, boost, and fuel pressure gauges by DiProcol on the pillar

Plus a few other odds and ends...
shu873 is offline  
post #9 of 12 Old 04-02-2009, 07:19 PM
Compression Ignition Addict
 
03f250stroke's Avatar
 
Join Date: Sep 2007
Location: Toms River, NJ
Posts: 3,720
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to 03f250stroke
Kurt is right..you need to check your i/c boots..check the one coming off the turbo, it likes to rip under the clamp. also the boot coming off the i/c going into the elbow there for the intake manifold

my truck would make like a train horn sound and it was just a boot...cheapest fix i ever had to do

-Evan

6.HO
tuned by Eric
12.3

Quote:
Originally Posted by shu873 View Post
Yeah, but your trucks a freak of nature...
03f250stroke is offline  
post #10 of 12 Old 04-02-2009, 07:20 PM Thread Starter
Member
 
Join Date: Mar 2009
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
There is coolant spitting out of the coolant res. I thought it was just a bad cap or something.
sobrien1130 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome