P0266 Any info - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-26-2009, 06:16 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2007
Location: Canyon, Texas
Posts: 96
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
P0266 Any info

The truck sat for a couple of days and I started it up to move it today. When I cranked it kinda sounded like the batteries were dying about the time the engine hit Top Dead Center. I let the glow plug light go off and cranked it the engine cycled twice and on the third time around it started. I went to town to get fuel and on the way I checked for trouble codes, P0266 was the only one. I cleared it and no codes now. Cyl # 2 Contribution/ Balance fault. So I guess I have an injector going bad now? It is a 2005 6.0 with only 40,000. Is there anything to be concerned about? I do need to take it in for a vibration at about 35 mph, and only if you are trying to keep that speed by barely pushing the throttle down. I figure I'll mention the code when I take it in. Any input would be appreciated. sorry for the long post. And I did just change the fuel filters about 4 weeks ago.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-26-2009, 06:23 PM
Rice Hunter
 

Join Date: Aug 2007
Location: Norfolk,VA...Near the beach
Posts: 4,036
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
for techie
Reply With Quote Quick reply to this message
  #3  
Old 03-26-2009, 07:20 PM
Premium Member
 

Join Date: Feb 2007
Location: Wisconsin
Posts: 1,366
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
How does it run? Sometimes when the batteries go low there will be random codes set. Does it clear and stay off? If theres a misfire or something you need to run a buzz test, and most likely replace the injector. If its running fine clear the code and run it, it may just be from the low battery voltage. Usually when low battery voltage sets codes there is alot of codes tho...
Reply With Quote Quick reply to this message
  #4  
Old 03-28-2009, 10:38 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2007
Location: Canyon, Texas
Posts: 96
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the info. It Runs great except a low speeds like explained above. I will try running the buzz test. Sorry for not replying sooner I've got the flu so when I get to feeling better I'll try it.
Reply With Quote Quick reply to this message
  #5  
Old 03-29-2009, 08:34 AM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Bolton
Posts: 786
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Might of been the cold start with low bat, glows didn't put out enough so the first few cycles were misses. Was the start rough?

Clear it and look for it again.
Reply With Quote Quick reply to this message
  #6  
Old 03-29-2009, 11:21 AM
Powerstroke.org Fanatic
 

Join Date: Aug 2007
Location: Canyon, Texas
Posts: 96
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The start was a little rough. but it cleared right up. And the code has not returned yet.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:19 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors