lack of power - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-26-2009, 11:18 AM
Powerstroke.org Rookie
 

Join Date: Feb 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
lack of power

I have a 2004 f-350 6.0 with 76000 miles it has a cold air intake and thats it i sometimes have no power in the mornings when i first take off it acts like it is not getting fuel then it fine but later on in the day i can be driving and it will just start to lose power i just replaced both fuel filters can someone please help
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-27-2009, 10:11 AM
Powerstroke.org Rookie
 

Join Date: Dec 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
might be your EGR valve and your EGR cooler. I had the same problem. But it keeps getting worse and worse. Might want to get that checked out.
Reply With Quote Quick reply to this message
  #3  
Old 02-27-2009, 10:19 AM
Compression Ignition Addict
 

Join Date: Jul 2007
Location: North Beach Md
Posts: 1,423
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
When you have a loss of power - is it puking black smoke? Then all of a sudden power comes back? When the engine is warm - probably the EGR.

Our 6.0 engines are designed to not have full power until up to operating conditions - so when its cold out - she will have reduced power till she warms up - then there is little stopping her!!! well - until that egr clogs then she chokes unitl she can hack the stuff out.

I unplugged my EGR = problem solved. On '04's the EGR unplugging will throw a code. You can try it though - see if the problem goes away.
Reply With Quote Quick reply to this message
  #4  
Old 02-27-2009, 11:26 AM
Powerstroke.org Rookie
 

Join Date: Feb 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
my egr does leak but it doesn't matter if it is warmed up or if its cold it just does it when it feels like it and it has never thrown a code
Reply With Quote Quick reply to this message
  #5  
Old 02-27-2009, 11:37 AM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,240
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
you need to take this truck in and get the latest recalibration from ford for cold start issues , that should fix it
Reply With Quote Quick reply to this message
  #6  
Old 02-27-2009, 08:41 PM
Powerstroke.org Rookie
 

Join Date: Dec 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by SCUFFY828 View Post
you need to take this truck in and get the latest recalibration from ford for cold start issues , that should fix it


THat worked for me!
Reply With Quote Quick reply to this message
  #7  
Old 02-28-2009, 12:42 PM
Powerstroke.org Rookie
 

Join Date: Feb 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
it already has it but it isn't just when its cold i can drive it all day and it may just start doing it
Reply With Quote Quick reply to this message
  #8  
Old 03-01-2009, 09:58 AM
Powerstroke.org Fanatic
 

Join Date: Jan 2008
Posts: 126
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
mine did that with 76,000 miles on it and i took it in. the dealer changed 2 injectors and fixed it. but about 11 months later it's doing it again.
but i also have an egr cooler and engine oil cooler leaking. so not sure if it's the same problem or not this time. sux trying to pass someone and it lays down on ya.
Reply With Quote Quick reply to this message
  #9  
Old 03-01-2009, 10:13 PM
Powerstroke.org Rookie
 

Join Date: Feb 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
im guessing it has to be the leak in my egr cause i know what an injector feels like i had that problem before i may just have to replace the egr ouchy
Reply With Quote Quick reply to this message
  #10  
Old 03-04-2009, 05:43 AM
Powerstroke.org Rookie
 

Join Date: Mar 2008
Location: Tahlequah, OK - Currently in Bangor, ME working
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to xrider82
Mine was doing that cold but not warm and it would cut out at 1500-1800 rpm ocationally. You could lay in the throttle n it would clean out and go. 3 injectors were bad.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:33 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors