Coolant leak!!! - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-15-2009, 03:49 PM Thread Starter
Compression Ignition Addict
DYNAMiTE's Avatar
Join Date: Jan 2009
Location: Forney, TX
Posts: 205
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Coolant leak!!!

Truck in my sig, It is puking coolant out of the resevoir and not just a little bit.... From a hour drive it covered my intake/battery/and driver side fender-well with coolant. When it is cold out it has a hard time starting and idles rough for about 30-45 seconds but no/very little white smoke.... I have headr of resevoir caps failing but dont think this is the case... Any ideas? I probably will take it to the dealer tomorrow 30k left on my warranty.

'07 F250 CC SB
4" Turbo back no cat/muff
S&B Intake
X3 ID Custom Tunes
2" lift 18" Black KMC Monsters w/33" Nitto A/T
Auto-Meter Trans/Boost/Pyro
Zoodad/High Idle mod
HID Head lights and fog lights
AMP Steps
No chrome anywhere!
DYNAMiTE is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome