big issues 03 6.0 - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

LinkBack Thread Tools Display Modes
post #1 of 5 Old 01-14-2009, 08:05 PM Thread Starter Fanatic
doughman's Avatar
Join Date: Dec 2008
Posts: 90
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
big issues 03 6.0

Ok having some issues with my 6.0l. It first started when i would bwe driving around town 45mph and step on it would get smoke. but if i reset computer would go away. Then went out on morning to start it and would not start. tried to test the relay, replaced relay and still no go. it would start on ether. Then i had to use it this past weekend to tow a car about 400 miles. i was about 2 hours into trip shut it off and no start. again reset computer and fired right up. Drove to drop car off and grabbed a bite to eat. unhooked batterys for about 20min while eating. No start till i used ether. then on the way back home embty trailer going up hill the truck would surge. looked down at boost gauge and seen that is i would boost above 12 my gauge would bounce about 4psi when the truck surged and could feel a thumb on my left foot. I did not know there is now blow off valve but that is what i thought it was. got it home parked it. plugged it in over night and the next morning it started fine. Took it to parts store and no codes in computer, it would also hold boost with no issues. brought it home cleaned air filter and mass air meter, and then i noticed the oil in the intake. so right now i am rebuilding turbo but was wondering if this was the cause of my issues. i will clean the egr tomorrow and hopfully have turbo ready to go back in. if you guys have any other ideas on the issues please let me know.
doughman is offline  
post #2 of 5 Old 01-14-2009, 08:09 PM
Premium Member

Goose350's Avatar
Join Date: Nov 2008
Posts: 13,271
Thanks: 0
Thanked 5 Times in 5 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 2 reviews
Dont know what to say but Welcome to the Org!

The Mullet Mod
Stock 2005 F-350 4x4
*Afe Intake
*4" TB Exhaust
*Bulletproof Diesel oil bypass
*Bulletproof Diesel water pump
*Tuned FICM
Goose350 is offline  
post #3 of 5 Old 01-14-2009, 08:28 PM
Compression Ignition Addict
Cory S's Avatar
Join Date: Aug 2008
Posts: 2,464
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to Cory S
welcome to the org i dont know anything about 6.0 someone will come alon to help

2000 XC 4x4

Orlando, FL
Cory S is offline  
post #4 of 5 Old 01-14-2009, 08:55 PM
Compression Ignition Addict
IUStroker6.0's Avatar
Join Date: Mar 2008
Location: Bloomington, Indiana
Posts: 672
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
hmm sounds like you definitely had some blow by in your intake. what do you mean by you are rebuilding the turbo? what was wrong with your turbo? seems like there are some weird internal issues going on if you have checked your mass air and egr and it is still doing it.

2004 F-350 Reg Cab Long Bed 6.0l: Sold

2007 Dodge 2500 5.9l Cummins
White Quad Cab Short Bed 4x4
All stock
IUStroker6.0 is offline  
post #5 of 5 Old 01-14-2009, 09:06 PM
scuffs *****

Tyler's Avatar
Join Date: Aug 2008
Location: Oakwood, OH
Posts: 5,270
Thanks: 0
Thanked 10 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to Tyler
NEVER use ether to start your truck. Not sure what the problem is though. Love my 7.3, but like I said, a lot of ppl here will smite you for using ether.

Sr. Engineering Tech/OPS Technician @ Your local cable company.
1997 7.3L PSD
| 4" MBRP Exhaust | S&B CAI | Torque Converter Lock-Up Switch | Exhaust Brake | FPR Shim |DB High Torque Starter | 188,000 Miles | Xtreme Daily Tune | SOLD

2014 Ford Fusion SE
| 1.6 EcoBoost | 6-Speed Manual | The basics and some goodies |
Tyler is offline  

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome