Problem after speed bump 06 powerstroke - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-04-2008, 10:30 AM
Powerstroke.org Rookie
 

Join Date: Dec 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Problem after speed bump 06 powerstroke

i was going out of town when the truck started to loose power i had to keep it at a 70mph because if i let off it would take long to speed up again. so i got to a parts store and bought the fuel filters and replaced them the truck worked alot better. so i got on the road again at about 75mph it was dark and i did not see a huge speed bump i jump up dont know how high but after that the truck started to sputter and no power it was hard for the truck to get speed up but it got me to my destination.the truck is still sputtering and has no power i also hear the fuel wine loud.
im not sure what could be wrong. i hope u guys can help me.
the truck is an 06 F350 4x4 lariat 108000miles
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-04-2008, 10:32 AM
Compression Ignition Addict
 

Join Date: Aug 2008
Posts: 2,466
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to Cory S
ouch that doesnt sound good is it one of those things that will clear up after sitting for a while?
Reply With Quote Quick reply to this message
  #3  
Old 12-04-2008, 10:43 AM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,242
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
make sure inertia switch is pressed down
Reply With Quote Quick reply to this message
  #4  
Old 12-04-2008, 10:58 AM
Premium Member
 

Join Date: Jun 2008
Location: Around
Posts: 1,042
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
psd

it sounds like you knocked something loose
Reply With Quote Quick reply to this message
  #5  
Old 12-05-2008, 08:32 AM
Powerstroke.org Fanatic
 

Join Date: Oct 2008
Location: Beeville, Texas
Posts: 148
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Where were you that you could be going 75mph and hit a speed bump?

And perhaps you should look to make sure you still have shocks
Reply With Quote Quick reply to this message
  #6  
Old 12-07-2008, 05:45 AM
Banned
 

Join Date: Feb 2008
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
probly a bad fuel pump if its whinning loud, try checking fuel pressure.
Reply With Quote Quick reply to this message
  #7  
Old 12-12-2008, 01:14 PM
Powerstroke.org Rookie
 

Join Date: Dec 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mexico highway
Reply With Quote Quick reply to this message
  #8  
Old 12-12-2008, 01:15 PM
Powerstroke.org Rookie
 

Join Date: Dec 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i the mechanic replaced 3 injectors and the truck is workin fine for now.
Reply With Quote Quick reply to this message
  #9  
Old 12-12-2008, 01:35 PM
Premium Member
 

Join Date: Jun 2008
Location: Around
Posts: 1,042
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
psd

how does going over a speed bump cause the injectors to go bad?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:35 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors