2005 Blinker Issue - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 03-25-2014, 10:54 AM Thread Starter
Powerstroke.org Fanatic
 
nolefanreed15's Avatar
 
Join Date: Dec 2011
Posts: 104
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
2005 Blinker Issue

Two months back I installed led's in all blinkers/running lights on the truck. Put in an led flasher from advanced, and everything worked normal for at least 4-6 weeks. Recently however I opened the door to the truck and noticed a clicking sounds, narrowed it down to be the flasher just randomly clicking. When the clicking occurs, nothing is flashing at all just the sound that you here with blinkers.This clicking occurs at random speeds truck on or off and seemed to go back to normal speeds when using the blinkers. I replaced the flasher (thinking that was the cause) and to my surprise the clicking pursued. It seems the issue has either gotten worse or I didn't notice some symptoms at first. Now with the truck off and key out sometimes if I hit the blinker switch it will flash a few times then turn off. When the truck is on and I use the blinkers they will slow down or speed up randomly. I took this too ford and they did an extensive electrical diag. which ended in them not knowing for sure what it could be. They thought either the entire fusebox (roughly $580 for parts) or the multi function switch (Blinker switch about $180). Any thoughts?

-2005 F250 6.0, EGR Delete, Oil Cooler Upgrade, ARP Headstuds, 5" MBRP Exhaust, Blue Spring Upgrade, SCT X3 w/ IDP Tunes, 17" MetalMoto's, 35" Toyo Mt's, Retro Solutions 55 watt HID Headlights, Xenon Fogs, 08 Tail Lights

nolefanreed15 is offline  
post #2 of 3 Old 03-25-2014, 11:34 AM
Super Moderator

 
Heavy_GD's Avatar
 
Join Date: Aug 2013
Location: 804Va
Posts: 13,014
Thanks: 3,604
Thanked 982 Times in 923 Posts
Mentioned: 90 Post(s)
Quoted: 1077 Post(s)
Feedback Score: 3 reviews
take the LEDs out to isolate the issue.

GD - 06 CCSB FX4 Lariat

https://www.gofundme.com/2464axqr

Quote:
Originally Posted by 6.0Stroker View Post
It's Toren. .. don't question it ..
Heavy_GD is offline  
post #3 of 3 Old 03-25-2014, 11:49 AM Thread Starter
Powerstroke.org Fanatic
 
nolefanreed15's Avatar
 
Join Date: Dec 2011
Posts: 104
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Would simply removing them without putting incondesant bulbs back in "isolate" the issue? Or would I have to go out and buy all new bulbs? just wondering before I spend money unnecessarily


Sent from AutoGuide.com Free App

-2005 F250 6.0, EGR Delete, Oil Cooler Upgrade, ARP Headstuds, 5" MBRP Exhaust, Blue Spring Upgrade, SCT X3 w/ IDP Tunes, 17" MetalMoto's, 35" Toyo Mt's, Retro Solutions 55 watt HID Headlights, Xenon Fogs, 08 Tail Lights

nolefanreed15 is offline  
Reply

Tags
blinker , click , flasher , led , switch

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome