interesting coolant leak - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-24-2008, 02:25 PM
Compression Ignition Addict
 

Join Date: Jul 2007
Location: southeast, Texas
Posts: 285
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
interesting coolant leak

I have had a coolant leak for quite sometime now... My egr system has been completly deleted so it has nothing to do with that.

I can figure out exactly were the leak is coming from but coolant is driping off the bottom of the driver side block onto the lip of the oil pan and driping down to the ground from there.

it doesnt leak bad on long trips but if I start the truck up cold and drive it 5-10 miles down the road and stop it leaks pretty bad. If I start it up cold and drive it 50 miles to work when i come to a stop it doesnt hardly leak if any at all.

This doesnt make any since to me but maybe one of ya'll have had or heard of a problem like this.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-24-2008, 02:27 PM
Viking Heavy Diesel

 

Join Date: Nov 2007
Location: 34'.6264 -98.4192
Posts: 20,704
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
I dont know what it could be but heres a bump for ya.
Reply With Quote Quick reply to this message
  #3  
Old 11-26-2008, 06:27 PM
Powerstroke Diesel Enthusiast

 

Join Date: Dec 2006
Location: Grey Bruce County
Posts: 223
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Invest in a coolant pressure tester, it sure beats the hell out of guessing where the coolant is coming from. Pressurize the system and get out a flashlight and a mirror and start searching. You said you deleted the EGR but could your "repair" also be the leak??
Reply With Quote Quick reply to this message
  #4  
Old 11-27-2008, 07:25 AM
Compression Ignition Addict
 

Join Date: Jul 2007
Location: southeast, Texas
Posts: 285
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
no sir, that is the first place I checked..... I figured it was the hose I ran from the Egr cooler delete to the oil cooler, but its dry as a bone.

I will try and get ahold of a pressure tester tomarrow... thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:16 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors