Another no start.... - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 03-16-2014, 06:26 PM Thread Starter
Powerstroke.org Rookie
 
Point-X's Avatar
 
Join Date: Jan 2013
Location: Ajax
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Another no start....

So last sunday after parking my truck and going into a store it wouldn't start. My friend brought it to his shop where he found a bad ground on the ICR. Problem solved. I picked it up today and while leaving his place I lost power then it just died. I didn't even make it to the end of the road. He scanned it and the ficm was 48v and the icp pressure was over 1300. we disconected the icp to see if it would fire in limp mode. Nothing. Checked the fuel filter and it was full and not gelled. It -14c and we gave up and towed it back to the shop. Gonna look at it tomorrow. Any ideas are appreciated
Point-X is offline  
post #2 of 7 Old 03-16-2014, 07:36 PM
Compression Ignition Addict
 
x148's Avatar
 
Join Date: Jan 2012
Location: East Bridgewater, MA
Posts: 230
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
With the scan tool did you read Ipr percentage?

05 F350
-Sinister EGR Delete
-Banks High Ram
-Blue Spring
-Air Dog II
-K&N Intake
-H&S Mini Max
-Swamps 58v FICM
-03 Turbo
-5" MBRP turbo back
-ARP Head Studs
-Cat ELC1 Coolant
-6" Lift on 37" Toyo M/T
-Detriot True-Trac with 4.56 Gears
-Pro Comp Trac Bars

x148 is offline  
post #3 of 7 Old 03-17-2014, 07:18 AM Thread Starter
Powerstroke.org Rookie
 
Point-X's Avatar
 
Join Date: Jan 2013
Location: Ajax
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It was pegged at 84.9%
Point-X is offline  
post #4 of 7 Old 03-17-2014, 07:29 AM
aka MacGyver
 
rick1067's Avatar
 
Join Date: Oct 2013
Location: Phenix City Alabama
Posts: 153
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Point-X View Post
So last sunday after parking my truck and going into a store it wouldn't start. My friend brought it to his shop where he found a bad ground on the ICR. Problem solved. I picked it up today and while leaving his place I lost power then it just died. I didn't even make it to the end of the road. He scanned it and the ficm was 48v and the icp pressure was over 1300. we disconected the icp to see if it would fire in limp mode. Nothing. Checked the fuel filter and it was full and not gelled. It -14c and we gave up and towed it back to the shop. Gonna look at it tomorrow. Any ideas are appreciated
I would take a look at either your IPR or the STC Fitting.
rick1067 is offline  
post #5 of 7 Old 03-17-2014, 07:32 AM
Compression Ignition Addict
 
x148's Avatar
 
Join Date: Jan 2012
Location: East Bridgewater, MA
Posts: 230
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Ipr is junk then if at 84/85%

05 F350
-Sinister EGR Delete
-Banks High Ram
-Blue Spring
-Air Dog II
-K&N Intake
-H&S Mini Max
-Swamps 58v FICM
-03 Turbo
-5" MBRP turbo back
-ARP Head Studs
-Cat ELC1 Coolant
-6" Lift on 37" Toyo M/T
-Detriot True-Trac with 4.56 Gears
-Pro Comp Trac Bars

x148 is offline  
post #6 of 7 Old 03-17-2014, 01:34 PM Thread Starter
Powerstroke.org Rookie
 
Point-X's Avatar
 
Join Date: Jan 2013
Location: Ajax
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Its an 03 so no stc fitting
Point-X is offline  
post #7 of 7 Old 03-18-2014, 03:18 AM
aka MacGyver
 
rick1067's Avatar
 
Join Date: Oct 2013
Location: Phenix City Alabama
Posts: 153
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Point-X View Post
Its an 03 so no stc fitting
Ok. I guess that narrows it down. LOL
rick1067 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome