Another no start.... - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-16-2014, 06:26 PM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Location: Ajax
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Another no start....

So last sunday after parking my truck and going into a store it wouldn't start. My friend brought it to his shop where he found a bad ground on the ICR. Problem solved. I picked it up today and while leaving his place I lost power then it just died. I didn't even make it to the end of the road. He scanned it and the ficm was 48v and the icp pressure was over 1300. we disconected the icp to see if it would fire in limp mode. Nothing. Checked the fuel filter and it was full and not gelled. It -14c and we gave up and towed it back to the shop. Gonna look at it tomorrow. Any ideas are appreciated
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-16-2014, 07:36 PM
Compression Ignition Addict
 

Join Date: Jan 2012
Location: East Bridgewater, MA
Posts: 230
Thanks: 2
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
With the scan tool did you read Ipr percentage?
Reply With Quote Quick reply to this message
  #3  
Old 03-17-2014, 07:18 AM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Location: Ajax
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It was pegged at 84.9%
Reply With Quote Quick reply to this message
  #4  
Old 03-17-2014, 07:29 AM
aka MacGyver
 

Join Date: Oct 2013
Location: Phenix City Alabama
Posts: 133
Thanks: 2
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Point-X View Post
So last sunday after parking my truck and going into a store it wouldn't start. My friend brought it to his shop where he found a bad ground on the ICR. Problem solved. I picked it up today and while leaving his place I lost power then it just died. I didn't even make it to the end of the road. He scanned it and the ficm was 48v and the icp pressure was over 1300. we disconected the icp to see if it would fire in limp mode. Nothing. Checked the fuel filter and it was full and not gelled. It -14c and we gave up and towed it back to the shop. Gonna look at it tomorrow. Any ideas are appreciated
I would take a look at either your IPR or the STC Fitting.
Reply With Quote Quick reply to this message
  #5  
Old 03-17-2014, 07:32 AM
Compression Ignition Addict
 

Join Date: Jan 2012
Location: East Bridgewater, MA
Posts: 230
Thanks: 2
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Ipr is junk then if at 84/85%
Reply With Quote Quick reply to this message
  #6  
Old 03-17-2014, 01:34 PM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Location: Ajax
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Its an 03 so no stc fitting
Reply With Quote Quick reply to this message
  #7  
Old 03-18-2014, 03:18 AM
aka MacGyver
 

Join Date: Oct 2013
Location: Phenix City Alabama
Posts: 133
Thanks: 2
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Point-X View Post
Its an 03 so no stc fitting
Ok. I guess that narrows it down. LOL
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:48 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors