zero power after hg.. please help - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-13-2014, 11:19 AM
Powerstroke.org Rookie
 

Join Date: Mar 2014
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
zero power after hg.. please help

Truck starts good idles good but has no power. Wont power brake over 1000rpm. No codes. Did hg egr delete studs powermax and afe intake. Has 60psi of fuel pressure. Is full of oil. Ficm has propper voltage. When i take it down the road it will eventually get going and build boost but doesnt have the powerit should. Checked all intercooler boots unplugged icp checked ebp please help....also no smoke
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-13-2014, 12:09 PM
information regurgitator
 

Join Date: Dec 2010
Location: NYC
Posts: 5,903
Thanks: 18
Thanked 180 Times in 167 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by truckguy876 View Post
Truck starts good idles good but has no power. Wont power brake over 1000rpm. No codes. Did hg egr delete studs powermax and afe intake. Has 60psi of fuel pressure. Is full of oil. Ficm has propper voltage. When i take it down the road it will eventually get going and build boost but doesnt have the powerit should. Checked all intercooler boots unplugged icp checked ebp please help....also no smoke
You shouldn't get smoke.

Try sticking your foot over the exhaust pipe and listen under the truck and under the hood. Suspect a pre-turbo exhaust leak.
Reply With Quote Quick reply to this message
  #3  
Old 03-13-2014, 12:11 PM
Premium Member

 

Join Date: Sep 2008
Location: Oakbank, Manitoba
Posts: 2,831
Thanks: 6
Thanked 71 Times in 65 Posts
Feedback Score: 0 reviews
Quote:
Wont power brake over 1000rpm.
I have no clue what you are trying to convey.


Was anything else changed besides the HGs? The fact that it has no smoke is somewhat interesting in that it means you have either the right amount of fuel for the air, or not enough fuel. Most of the typical exhaust and boost leaks would be somewhat smokey while accelerating. The Powermax with stock injectors and no tune usually produces disappointing results with the slow to build boost symptoms you describe. It would smoke with a power tune. So you checked the values, what were they?

At Idle: ICP, IPR, EBP, Boost, VGT, Fuel Pressure and EGT

While accelerating with 14-50% pedal the same. Also add PW (pulse width). Note RPM when boost builds faster.

While accelerating at WOT, all of the above. What is your max boost? How does the truck shift?
Reply With Quote Quick reply to this message
  #4  
Old 03-13-2014, 02:18 PM
Powerstroke.org Rookie
 

Join Date: Mar 2014
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The truck builds 20 pounds of boost but is much slower then before. I have the scan guage and have to put more of the xguage codes in. Icp is reading 53 at idle and 110 wot. There is a very little smoke and i have an atlas 50 tune on the ficm. All connections checked multiple times. Fuel pressure holds steady at 60 psi. The pm intake hg and egr delete was all done at the same time. In park it revs slow and has a noticable miss. Ill put the codes in on the scanguage now and get you the other readings..thank you for helping me
Reply With Quote Quick reply to this message
  #5  
Old 03-13-2014, 02:48 PM
Powerstroke.org Rookie
 

Join Date: Mar 2014
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Icp 37 ipr 21.8 eb 17.5 vgt 71
Reply With Quote Quick reply to this message
  #6  
Old 03-13-2014, 03:57 PM
Premium Member

 

Join Date: Sep 2008
Location: Oakbank, Manitoba
Posts: 2,831
Thanks: 6
Thanked 71 Times in 65 Posts
Feedback Score: 0 reviews
Quote:
In park it revs slow and has a noticeable miss.
As you know, it should rev very quickly in Park, even with an injector not working. With more than one dead, that could give you your symptoms.

Quote:
Icp 37 ipr 21.8 eb 17.5 vgt 71
If these are Idle Parameters, the EBP is atmospheric and the IPR and VGT look OK. Boost would be about 0.3 psi. The ICP needs a better PID selection to read correctly. It should be about 600-800 psi or 0.9-1.2v depending on the temperature and idle RPM.

Ensure all the injectors are connected and the FICM plugs are clicked in to position (yes, check them again). All codes, if any would help. Are you absolutely sure that nothing dropped into the engine, heads or HPO system? You may need to pull the IPR to check the screen. Even though it idles, it may be sticking at a lower position than commanded. Same goes for the injectors and other parts, are you absolutely sure you installed parts correctly?

When you get some better ICP numbers, it may help track down the problem.
Reply With Quote Quick reply to this message
  #7  
Old 03-13-2014, 04:10 PM
Powerstroke.org Rookie
 

Join Date: Mar 2014
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Truck is now dropping oil pressure at idle. Afterrunning it i let it idle and pressure on dazh guage goes to 0. Raise rpm and it reads normal.i checked all plugs and connectors at least 10 times. Im positive it was reassembled correctly and took every precaution i could to make sure nothing fell in the motor
Reply With Quote Quick reply to this message
  #8  
Old 03-13-2014, 04:30 PM
Powerstroke.org Rookie
 

Join Date: Mar 2014
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Whats the max i can have milled off the heads? The machine shop said they were gonna cut like .008 off even though the heads were .004 out. I was told thiscould be part of my problem
Reply With Quote Quick reply to this message
  #9  
Old 03-13-2014, 05:41 PM
Premium Member

 

Join Date: Sep 2008
Location: Oakbank, Manitoba
Posts: 2,831
Thanks: 6
Thanked 71 Times in 65 Posts
Feedback Score: 0 reviews
You could be OK, but you need to ensure valve clearance as you are at the limit.

Your low pressure oil issue could be a red herring, but if your ICP is way off lower than expected and the IPR is going higher, you could have a low pressure pump issue. However, remember the low pressure gauge is not a gauge, it is a 7 psi switch. If your pressure was that low, the engine would probably not run or would run poorly.
Reply With Quote Quick reply to this message
  #10  
Old 03-14-2014, 03:35 PM
Powerstroke.org Rookie
 

Join Date: Mar 2014
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Icp is 700 at idle ipr duty cycle is 24 truck has zero power... did the bubble test on the injectors. No air coming up in fuel bowl. Fuel still steady at 60psi. Sat all night and started fine. Still revs slow...anyother ideas... should i pull all the push rods?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:32 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors