2007 f-250 Hubs wont auto lock and no ac ? - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 03-12-2014, 06:52 AM Thread Starter
Powerstroke.org Rookie
Join Date: Mar 2014
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2007 f-250 Hubs wont auto lock and no ac ?

I recently bought a 2007 f-250 and need help diagnosing the problem of my 4wd hubs not auto locking and my ac not working. 4wd works great when manually locked in and heat works great as well. The ac compressor does not run at all.I checked the vacuum pump by taking of a hose and blocking with my finger. It immediately shuts off as well as when I put the hose back on. Where should I check next?
White6.0 is offline  
Sponsored Links
post #2 of 2 Old 03-12-2014, 07:07 AM
Compression Ignition Addict
ZMANN's Avatar
Join Date: Feb 2008
Posts: 12,358
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 60 Post(s)
Thanks: 271
Thanked 534 Times in 503 Posts
Feedback Score: 0 reviews
you have 2 issues not related
the 4x4 system is easier look for the ESOF trouble shooting writeups the AC
is something you might want a shop to look at otherwise you need to see why the compressor isn't actuating
ZMANN is online now  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome