6.0 powermax blown seal??? - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-07-2014, 01:35 PM
Member
 

Join Date: Jan 2012
Location: Newark, DE
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.0 powermax blown seal???

Just put a powermax and 4" straight mbrp on the 2006 6.0. Truck was blowing blue smoke before I swapped. Pulled out the turbo and had about an eighth inch of burnt oil caked on the outlet and down pipe. Bought a powermax put it on along with 4" mbrp. 50 miles later she smokin blue like crazy at stoplight and I can take my finger and wipe the oil out of the exhaust tip. I'm not running any crazy tunes just a mid level tune from Eric @ innovative. Has anyone else had this much trouble with seals or could there be something else causing the oil???
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-07-2014, 01:54 PM
Serving Our Country!

 

Join Date: Apr 2012
Location: Florence sc
Posts: 972
Thanks: 7
Thanked 12 Times in 12 Posts
Feedback Score: 1 reviews
Send a message via Skype™ to Bluedemon6.0
I think you need to determine if the oil is coming from your motor or not. I find it hard to believe that you blew a seal that quick on a new turbo. I would disconnect the up pipe and the down pipe then look for oil residue going into your exhaust manifold. Did you pull the codes? Maybe an injector issue or hgs. A blown head gasket will smoke and the coolant will come out like soot (oily residue). Do you use any coolant or have you checked the pressure of your coolant system?


Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #3  
Old 03-07-2014, 02:16 PM
Member
 

Join Date: Jan 2012
Location: Newark, DE
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
no codes being thrown . no coolant loss. haven't pulled the up pipe since the new turbo install. when I pulled the old one the pipe was a little black but dry. not oily like the downpipe side
Reply With Quote Quick reply to this message
  #4  
Old 03-07-2014, 02:46 PM
Serving Our Country!

 

Join Date: Apr 2012
Location: Florence sc
Posts: 972
Thanks: 7
Thanked 12 Times in 12 Posts
Feedback Score: 1 reviews
Send a message via Skype™ to Bluedemon6.0
Got me. Another blown seal I guess then but why? Idk? Either way the turbo is got to come off,good luck and keep us posted.


Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:57 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors